GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Run as administrator in file/folder shortcut menu


#1

How do I get an item "Run as administrator" in the file/folder context menus? I searched on "Run as administrator" in the manual, but no hit.

Thanks/Hans L


#2

I'd say this is windows explorer's responsibility, not Opus'.

This might help:

Windows 10: Add or Remove Run as administrator Context Menu in Windows 10


#3

It should be there by default. If not, try holding Shift when right-clicking.


#4

Thank you, guys. It was not in Shift+RightClick either. I will read the WindowsTen tread.

Hans L


#5

Will not run Notepad as admin, since it is not recommended (and really cannot be done, as it seems). However, and it might be as bad, I am running UltraEdit as admin always. Problem solved by that. Thanks again!

Hans L


#6

You can run Notepad as admin without any issues. Who/where said it causes problems?


#7

Leo, I read somewhere on the web (a discussion about this issue) that it could make you vulnerable to viruses. If not an issue, would you kindly tell me how Notepad could be set to always run as administrator. I have tried, but the setting in question is always grayed out.

Hans L


#8

I don't think it makes sense to always run Notepad as administrator, but there's no extra risk from running an instance of Notepad as admin when you need to compared to running any other program as admin when you need to.

You can make a button, hotkey, filetype event or whatever you want in Opus to run Notepad as admin if you want that (use the @admin modifier in the Opus command). But that won't affect what happens if you launch Notepad via the Start Menu, if that's what you want. Holding Ctrl+Shift when launching it from the Start Menu will launch it as admin.


#9

Thanks, Leo. Will follow you instructions.