Run external command on selected file

Hello!

Trying to make a context menu (or button) to rename a .jpg file to a name that is based on the EXIF information in the file. The command line utility I've found is calld jhead and does the job perfectly when run from DOS. But I can't for the world get it to work inside Dopus!

The problem probably is that it uses % signs as part of the argument, cause when I run DOPTEST with the commandline it doesn't look like I want it. Heres what the command line would look in DOS

jhead -nf%Y-%m-%d--%H-%M-%S filename.jpg

When entered like above but with filename.jpg replaced to the currently selected file, doptest outputs;

doptest jhead -nfm-H-S pic9.jpg

Tried to replace the % with %% but the result is the same. When I try to replace % with % really strange things are happening that I can't really explain.

Can someone help me out here?

Oh, I, for some reason that I cannot really understand changed the function from "standard function" to "ms-dos function". Changing it back to standard function solved the problem (I used %% instead of %)

Hello,
Sounds Fun !
I'll look into this.

I told myself I wouldn't look at the Dopus Forum today.
I waxed my skis instead.
It was -7 to -10 Celsius with blue skies.
It was perfect. I skied 10K.
It hurt, but I feel good now.
Sadly, the snow will melt next week.

My Dopus name will no longer be Tsunami.
It was originally a joke to Brisbane.
The time for this has now past.
Also, there was a real world Tsunami tragedy today.
It is proper not to continue this name.

                           David Eaton :opusicon:

I know you have solved your problem but just for what it's worth if I was going to do something like this I'd put all the jhead commands in a batch file and then run that batch file from DOpus with a button command something like:

Mybatch.bat {f}

The reason I would do it that way instead of entering all the jhead parameters in a DOpus button configured as a MS-DOS batch function, is because DOpus does not have the full capabilities of a batch file. For example the simple batch file command of

Set X=

Which would normally set or clear a value for a batch file variable, fails miserably when used in a button.

John

Oh

The idea crossed my mind (to make a batch file) but I didn't try it. Thanks for the info.

Happy new year!