Run program from context menu

Hello, I am wanting to run the program "Unloker.exe" from the context menu of files and folders, for that I went to "File types" > "All files and folders" > "Context menu" and added the program, but this It is not shown, neither in files, nor in folders?

You'd normally want to pass the file path to the program, else it won't know what to run on. For that command type (which has to work in File Explorer as well), that means adding "%1" after the program path.

Does it appear when you hold shift as you right-click? If so, you've turned on the option to hide that type of entry. Creating it as "Run and Opus Command" instead will make it always show (since it becomes specific to Opus, instead of considered a general Windows context menu item).

(Also a general note about unlocker tools: They can cause serious problems if a handle is recycled and then the program that had the lock uses a handle it thought pointed to one file but which now points to something completely different. Unlocking tools should be a last resort, when even rebooting doesn't fix things. If you're using one enough to want it on a context menu, something is wrong somewhere else!)

1 Like

By right-clicking on what I hold down the Shifh key, the entry to the program appears, yes.

2023-09-10 19 00 23

If it is some configuration of mine in Opus, it will have been unintentional, since I have never had that intention. And I inserted "%1" at the end of the path, but it still does not appear.

The program works well from a button...

2023-09-10 19 19 51

To test, I added other programs to the context menu and they don't show up either, but when I go to Widows Explorer or Shift + Right-Click on Opus, the entries to the programs appear.

So it seems that it is the configuration that I have in Opus that is preventing these entries from being displayed. Does anyone know how I can change Opus's behavior so that it lets me see those entries?

It's probably the Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus option. If you turn that on it should show all the time without Shift needing to be held down.

Alternatively, if you set the function type to "Run an Opus function" rather than "Run an application" then it should show up whether that option is on or not.

1 Like

Yes, I have the Windows menu hidden because it is too large, and I applied your recommendation to use "Run an Opus function" instead of "Run an application" and it worked perfectly, thank you very much!