Seer Pro is not working on Windows 10

I've been using Seer Pro since last year. It provides instant preview for a file when pressing Space bar. A similar feature to QuickLook on Mac OS.

It works fine on Windows 11 but is no longer working on Windows 10. However, it just works in Explorer (Win10). I'm not sure but it seems to be not working as of v12.26 release.

The author of Seer Pro looked into the problem but couldn't figure out the reason.

Please help.


Wow, didn't know this thing existed! Would love to be able to use this with DOpus.


It's presumably intercepting the space bar in some way, and then working out which files are selected in the active window in some other way. What those methods are, and why it's failing and only failing on one of your machines but not the other, I couldn't even begin to guess as I didn't write it and know nothing about it.

Opus has an API which software can use to ask it which files are selected, but I don't know if it's using that or something else. We might be able to help with more detail, but can't do anything if we don't know anything about how it works or where it's going wrong.

It doesn't look like it installs a preview handler, which is the preferred way to add viewers to Windows.

@Leo, he would like to contact you by email. (

And here's what he did.

1. get the full path of Dopus.exe based on the Window Handle(GetForegroundWindow)
2. based on the full path from step 1 to find dopusrt.exe
3. then call command line "C:/full_path/dopusrt.exe" /info "C:/output_path/do_listsel.txt",listsel,0
4. then parse the do_listsel.txt to get the selected file path.

Before I get involved, has any analysis been done on the machine where things are going wrong? That would be my first step, and it'd require you to run some test commands.

Which part of the four steps is failing? Only the third step actually involves Opus, so if the problems is in the other three then I couldn't help.


Yes, it's the 3rd step. It works on some PCs, and fails on the others.

Is dopusrt.exe the API you mentioned before?

Opus has an API which software can use to ask it which files are selected

I mean, do we have any other way to get the selected file without reading/writting file?
Seer needs to track the selected file frequently, it would be great if we have anything without file operation.
Thank you~~

If you can't get Seer Pro to work with Opus on Win10, try QuickLook for Windows instead.
It has the same functionality and does work on Win10 (tested with v3.6.5; v3.7.1 is the current version)
Testing is easy as ther is a portable version too (make sure Seer Pro is not running at the same time)

QuickLook is free and open source.

Fails in what sense?

  • The exe isn't found?
  • There's no output file?
  • There is an output file but it's not containing the expected data?

As I checked the log file from spier, it is exe not found. But he can run the command in my code successfully in CMD window. Also the same Seer.exe works well in my test env in virtual machine.

+1 will probably buy this software if it worked with Dopus

1 Like

I don't know how Seer currently locates the exe, but there are a couple of ways you can do it:

  • FindWindow("DOpus.ParentWindow", NULL) and then use GetWindowThreadProcessId etc. to get the path to DOpus.exe and change the filename part to DOpusRT.exe (they'll always be in the same folder).

  • On a HDD install of Opus, you can also lookup the path in the registry, but that won't work with a portable install.

Using the window method probably makes most sense for something that reacts to a keypress in the Opus window, since you know Opus is running in that case.

The main advantage of the registry method is that it'll work when Opus isn't running, but that isn't useful here. However, for completeness, the registry data is here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\DOpus.exe

Is Opus running elevated? UIPI can prevent those programs from 'talking to ecah other'
Or dopusrt.exe, running as a regular user, is unable to 'talk to' dopus.exe as that is running elevated.

(all untested; just trying to help ... )

I've switched to Seer from QuickLook. It is not responsive and freezes frequently.

Problem solved by other method.

1 Like

might you share what other method was? it may help others

1 Like

The latest version 2.8.4 works well on Windows 10.

@Corey Thanks so much for the update!

1 Like

Still not working here after downloading Seer-2.8.4 fyi

Tried with 2.8.4; still not working.