Selecting .MP4 files with the preview panel open makes DOpus crash

I get the message: "Error 0x0000005 in the thread dopus.viewpaneloader at the address 0x000007FEE22BE99D".
DOpus 12.7 b6540 x64 under Windows 7 ultimate 64 bit

Opus itself does not decode MP4 content. The problem will be with a video demuxer or codec installed on your system, crashing when asked to decode that particular file.

If you have installed a codec pack (not really needed or recommended these days, in most cases), make sure it's fully up to date. In other situations, updating or replacing individual codecs/demuxers may be needed to avoid the crash with particular files the ones you have installed have problems with.

My version of VLC player is the last one (3.0.1). And it is the viewer associated to all my video files.
The same operation with other video files does not make crash.

The crash happens only with mp4 files launched in DOpus Preview panel. It does not happen when launched in DOpus out of the Preview, and does not happen when launched from windows explorer.
It seems a problem of the preview panel of DOpus.

VLC is unrelated to the viewer pane or codecs/demuxers on your system. It has its own codecs/demuxers baked in and does not use the shared ones.

Explorer (and other movie players) may be using a different method to play the video, or it could be a difference between the 32-bit and 64-bit codecs/demuxers, which could be different versions or entirely different components, or could have bugs that only affect one bitness.

You can make Opus use a different method of playing movies by disabling the Movie plugin (which uses 64-bit codecs). It will then use the 32-bit Windows Media Player's ActiveX control by default. If you configure the ActiveX plugin in Opus, you can also opt to use a 3rd player which is the same one that File Explorer uses, by turning on the Windows Media Player Preview Handler (which is different to the ActiveX control).

Using the Windows Media Player Preview Handler will give you the same results you see in Explorer, if that's what you want. But the crash you were seeing will be due to a codec or demuxer which may still crash in other software that uses it.

(Note for other people: Microsoft completely broke the Windows Media Player Preview Handler in Windows 10 a few months ago and still haven't fixed it. It's a decent option for Windows 7, but may not work in Windows 10 until Microsoft get around to fixing it. Similar problems are true in File Explorer and Outlook, which can currently not play videos at all in Windows 10. Using the ActiveX control still works in Opus.)

OK, I have disabled the Movie plugin, and DO crashes no more. With a single click I see in the preview the first frame of the MP4 file, or with a double click launch it in a VLC player window. That is not the best, but lets me work. Can you suggest a trick to find what is the codec/demuxer that is conflicting with the Movie plugin, please? I have several audio and video programs, and I cannot try to remove them one by one.

If you only see a preview of the first frame, it's falling back on the file's thumbnail.

That suggests the Windows Media Player ActiveX control is not working (for that file) for some reason. (It could be that it has similar problems with a codec/demuxer and that file, and the bug may not cause a crash in some circumstances but still causes playback to fail. Or it could be that the WMP ActiveX control isn't working at all.)

Have you tried using the WMP Preview Handler as I suggested above?

Have you tried any other suggestions in the guide I linked to above? For example, temporarily assigning .mp4 to Windows Media Player should make it repair its registry settings, and that may fix its ActiveX control.

I have reassigned .mp4 to WMP but nothing happened.
I don't know how to get/use the WMP preview handler

  • Go to Preferences / Viewer / Plugins.

  • Configure the ActiveX + Preview + Office + Web plugin.

  • In the Preview Handlers section of the list, at the top, turn on the Windows Media Player option.

(This is good on Windows 7. On Windows 10, it may not work as Microsoft broke their viewer. More detail above.)

Done, nothing different happens.

WMP 64bit plays those files. DO preview does'nt.

Done! While enabling WMP in Active X+..... I had to add .mp4 files to the list in the box. Now WMP plays in the preview panel. Many thanks!
Again, can you suggest a trick to find what is the codec/demuxer that is conflicting with the Movie plugin, please? I have several audio and video programs, and I cannot try to remove them one by one.

Something has definitely messed up your .mp4 filetype. Following the earlier suggestions, in the guide and repeated above, about associating mp4 with WMP to repair the registry settings would have fixed that.

Suggestions are in the guide I linked.

Thank you very much.
You can close the thread.