Sending via GMail silently fails

So I though I'd give the GMail support as announced for version 11.11 a try, and configured it with my account (port 587, TLS). However, whenever I was trying to send a file to myself ("to" equals "from"), I quickly saw the send mail progress dialog popping up without any further message, in particular no error, but still no mails arrived to my account. Any idea what's going on?

Which SMTP server are you configuring Opus to use?

The official one,

Do you have two step authentication turned on on your google account? If so, you need an 'application specific' password, NOT your normal google/gmail password.

No, two step authentication is turned off (and even if it was turned on, and if there was an error due to that, I'd expect to be notified about it). I also have enabled access for "less secure apps" for my Google account.

I'm not sure then, it works on my setup. Had to enable an app specific password though as I do have two step authentication turned on; it's caught me out before!

These are my settings:

I see you're suing port 465 (i.e. SSL) whereas I'm using port 587 (i.e. TLS). Does it work with the latter for you, too?

Yes, port 465 works but I see the same problem with port 587.

FWIW, I've always used port 465 for SSL/TLS option in email clients.

I've recently read somewhere that Google is discouraging the use of "pure" SSL in favor of TLS, hence my use of TLS and port 587.

@leo: So the problem is acknowledged from your side and I can expect a fix soon, right? :slight_smile:

I think this is something to do with Opus as I've just set up MS Outlook to use gmail and used TLS port 587 and this worked ok.

We've reproduced it, yes. I can't say when it will be fixed yet as we need to investigate further.

Please use port 465 as a workaround for now.

This will be fixed in the next update.

So I've just tried the beta 11.12.2. With that, I get "SMTP connection error" if I use port 587 with, no matter whether I choose "Automatic", "TLS", or "SSL" in the settings. So at least there's an error message now. But my understanding was that this beta should fix sending over port 587, or am I missing something? Sending over port 465 still works.

Also, if I choose port 465 but explicitly specify TLS for testing (which is wrong, as this port is supposed to be used with SSL only) Opus hangs indefinitely in the "Sending..." dialog and the "Abort" button does nothing.

"SMTP connection error" means either the socket() call failed (unlikely), or the connect() call failed (more likely). So this is happening before TLS/SSL is even trying to be negotiated. Check that you have the correct host name, and that your ISP and or firewall isn't blocking the connection.

Confirmed, this seems to have been a firewall issue blocking port 587. Thanks!

Thanks for letting us know!