Set double-click a ZIP archive file to automatically extract/unzip

Hi there,

i've set this setting in opus:

image

But when i click ctrl+double click on zip file it opens the zip on right side opus lister.

What am i doing wrong?

Thanks,
Manuel

The auto-extract option there is for double-clicking things like .exe files inside of archives. It doesn't do anything for double-clicks on the archives themselves (unless you have an archive inside another archive, but it wouldn't do anything very useful with those).

It's documented here: https://www.gpsoft.com.au/help/opus12/index.html#!Documents/Prefs/Archive_Options.htm

If you want double-clicking an archive (with or without Ctrl held down) to extract the archive, that should be done via Settings > File Types, and the Events tab of the type or group you want to edit.

Editing the Archives file type group there makes the most sense, as it will cover all your archive types (not just zip).

The command to extract an archive into a sub-directory with the same name is:

Copy EXTRACT=sub HERE
2 Likes

Thanks Leo. Works like a charm!

1 Like