SetAttr META MKV files Wn 10

In windows 7 was using a modified Tagger that put the year into Comment Column with SetAttr META
Or with a button for seperate files SetAttr META "comment:{dlgstring}"
But in windows 10 it does not add anything for .mkv all other files and folders are OK.
MKV files that were tagged in windows 7 still show in windows 10 Pro in DOpus 11.16 x64

Current versions of Opus don't know how to take MKV files by themselves, but if a shell extension is installed which knows how to then Opus could have been using that for certain metadata fields.

Whether that's the case, and what the component which was being used is, I couldn't say for sure. If there was one, it probably came with some video-related software.

I have the same issue as onedot3 reports. My system is windows 10 Home, DOpus 11.16 x64.
I found that for mkv files, if I temporarily delete or change the .mkv extension, the SetAttr META works and rating, tags are saved.
Then I write back the .mkv extension, and the file rating and tags stay OK.
Subsequently I can clear the tags, but not the rating; to clear the rating I have once again to temporarily delete the .mkv extension (or change it to .m, or .mk, or .mkva, etc.)
Any clues to help solve this issue?
Would uninstalling Dopus and then reinstalling it help? I am afraid to lose the thousands of tags and ratings I have already set if I do this.

  • Run ShellExView 64-bit version.
  • Sort by the Type column.
  • Find and disable all Property Handler extensions.
  • Reboot.

Is the problem still there?

If it is no longer there, start re-enabling them to find out which one was breaking things.

Thank you Leo, it worked !
Had to disable the extension "Media Foundation MKV Property Handler" (MS Windows Operating System).

Glad it helped.

It's strange that that particular one caused problems, since it's part of the OS and not causing any issues here, as far as I can tell.

Yes, it is strange indeed. I could try a different approach if and when it becomes available.

[quote="seba11"]Thank you Leo, it worked !
Had to disable the extension "Media Foundation MKV Property Handler" (MS Windows Operating System).[/quote]

Thanks seba11 and Leo for a fix.

Have just tried and it works for me as well.
Are you leaving "Media Foundation MKV Property Handler" disabled all the time or re enabling it after tagging your mkv's.
If it needs re-enabling is there a way to make a button to toggle it

Never thought of changing .mkv to something else.
What I did as a work around was use an old PC running Vista and do batch tagging in Vista.

Off to do some tagging :thumbsup:


Onedot3, I don't know if re-enabling the MS MKV handler brings benefits.
So I leave it disabled all the time, and my MKV tagging/untagging in Dopus now works as a charm.
Wish that future versions of Dopus could come knowing how to take MKV and other movie files, and handle the metadata fields in a way fully compatible with the MS Windows Operating System handlers. Could the movie viewer plugin perhaps be reworked to deal with metadata fields too?