Setting column width in the File lister

Since I upgraded to DoPus v10, I notice that the column width in the file lister is no longer "fixed"; instead, it varies by the length of the filenames in the directory selected in the left pane.

I liked the behaviour in DoPus 9 better -- where I set the width the first time I opened the lister, and it retained it from then on.

I've done some forum searches about this, and one of them suggest turning off column auto resize in Folder Options -- Folder Formats -- but I have so such options when I open that in Preferences.

So, how to I set an option to NOT auto resize the columns?

The "new look" date columns are terrible! I can't get the column widths to stick at all, and the alignment is all messed up. It appears they are aligned right and can't be changed.

Please revert behavior of the date columns back to DOpus 9 standards. They worked well.

Thank you.


If you hover your mouse over the padlock at the bottom of your lister you will see which folder format is controlling your display.

You can then edit the relevant format (e.g. Content Type "Documents" in this case) to make it behave the way you want.

Regards, AB

Follow AussieBoykie's advice and/or read the Folder Formats FAQ.

What's wrong with them being right-aligned? It makes the dates and times line up properly if you have leading zeros turned off, and makes the year parts line-up if you have month names (Jan, Feb, Mar, etc.) instead of numbers.

It would be terrible if the date/time columns were left-aligned.

Presumably your real problem is that the date/time columns are being truncated, not how they are aligned, but that's easy to fix by adjusting your folder formats.

I just discovered Directory Opus v10 a couple of days ago and find it has a lot of really nice features. I have been working my way through all the preferences, the manual and this forum and did quite a bit of experimenting with the folder options, I found a setting in folder options-display for 'auto-size columns' that was selected by default and wondered if de-selecting this might help.

Depends what your aim is. :slight_smile:

You want auto-size on if you want the columns to be automatically sized to fit whatever is in them without truncation.

You want auto-size off if you want the columns to use a fixed width (which may be too wide or too narrow for whatever is in them).

If auto-size is on but the columns aren't auto-sizing, it's because some other folder format (which might include Layouts, Styles or the Default Lister) is overriding things. AussieBoykie's post and the folder formats FAQ explain how to fix that.

Leo, your replies seem to imply that this is how DOpus always behaved, but that simply isn't so. I'll try aussie's "fix" or tweak, but all I can say is that in four years I have never had to make these kinds of changes in order to get the columns to act decently. Something definitely changes with the column width behavior.

Thank you.



Maybe in the past you had folder content detection switched off and now you have it switched on?

Regards, AB

No, I always had it turned on, aussieboykie. And I never had any issues like this with column width before!



The column is slightly wider in Opus 10 than it was in Opus 9. (There's a bit more space between the date and time parts to make it easier to read.)

So you may need to edit your folder formats to make the column a bit wider to stop it being truncated. (Or to turn on the option to auto-size columns.) Nothing about the way column widths or auto-sizing are handled has changed, though.

Update: We must be looking at different DirOpus 10 versions because mine ( does not have the options others have mentioned.

For example, in Preferences, I have no Folder Options. Instead, I have Folders, and under that, Folder Behaviour, Folder Display, Folder Formats, and Virtual Folders -- and in NONE of them, is there an option for Auto-size or anything like that.

When I hover my mouse over the "lock" at the bottom of the panel, ALL I get is Default Format. No Content Type is shown at all. So, obviously, I can not edit a content type when none is listed.

And ... checking the Preferences again, under Folder Behaviour, the Enable Folder Content Detection ... box is NOT checked.

So, once again, I have to iterate that this was NOT the way that DoPus ver 9 worked. Something is different in v10 FORCING auto-sizing of the columns and I want to turn that OFF.

OK ... I just FOUND it! Under the Preferences, under Default Formats --> Custom, in Display --> View. THERE is the check-box for Auto-size. I unchecked THAT box and the display does not auto-size anymore.

Version 10 is driving me nuts because of a related problem. At least I think it's related:

I use a dual window lister setup and I keep the windows pretty narrow. I use a list view for the files and I don't use any special views for different file types. I like to keep things pretty boring and simple.

The problem is that if I navigate to a folder full of files with long file names that are longer than the width of my lister, the damn window will scroll to the right by default and fool me into thinking that the entire folder is empty. This has freaked me out multiple times now into thinking that my files were missing. I have to use the mouse wheel or the slider at the bottom of the window to scroll back to the left so I can see the files.

WAWood8's method above of unchecking the auto-size option works and keeps the lister window from scrolling to the right, but then it obviously shortens the names of my long files and that's even more annoying.

I haven't changed a single setting from my setup with the previous version 9, so obviously something has changed with the way version 10 views things. Any ideas?

I can't reproduce that. Some screenshots might help re-create what you're seeing.

This is what I see when I open a folder that has a file with a long file name. Note that the slider at the bottom of the lister window is over to the right. This make the folder appear empty:

I have to scroll over to the left to actually see the file:

This is what I see:

It's possible this was fixed in one of the recent betas, please try the latest and file a formal bug report if it still happens.

I'm checking in to confirm that this was fixed with the latest update. Thanks everyone!

I don’t know... I keep reading here how nothing - or nothing much - has changed regarding column width settings from DOpus 9 to 10, but I sure am having to fix column widths in folder after folder, some of them more than once. I never had any problems with this in DOpus 9.

So far I find DOpus 10 more difficult to configure the settings and slower to perform most file operations.

Thank you.


The only thing that have changed with column widths:

  • Date-Time columns are now slightly wider than before, so if you had fixed-width columns with them in you might have to expand them a bit.

  • Auto-size is on by default (which probably won't affect you if you imported, or installed on top of, an Opus 9 config).

If anything else is different/wrong then you'll have to explain what it actually is so we can investigate it.

AFAIK, column-width configuration has not changed one iota. (If I'm wrong, please give examples so we know what they are and they can be addressed and/or explained.)

We've had a bunch of threads about improving file copy speed by turning off options to copy metadata/attributes, or in rare cases (usually USB drives) changing the copy buffer size, or even rarer cases updating hardware drivers, anti-virus, etc.. Without knowing more about yoru system I'm not sure which of those might apply to you. I'd like to summarise all the info into a FAQ at some point but don't have time right now. (If you want to go further with this point, please start a new thread so this thread remains about column widths.)