Severe Opus and Windows 10 thumbnail problems

I have a clean install of Windows 10 Home Edition, build 1709. Aside from hardware drivers and Opus 12.7, nothing's been installed on it.

When I open a folder in Windows Explorer and display its contents as thumbnails, all is well - all the files are thumbnailed correctly (aside from those for which I don't currently have the codec installed, of course). However, if I then point Opus at the folder and set the display mode to Thumbnails, problems ensue.

This specific folder contains a mixture of .mpg and .mp4 files, although the problem is most definitely not confined to these! The Movie plugin is configured to not generate thumbs for these, so Opus will go to the Windows Shell for them.

At best, Opus will load a smattering of the thumbs - and bear in mind that every single one of the files in the folder has a thumbnail stored in the Windows thumbnail cache. The remaining files are apparently skipped. Things then get worse: once this has happened, all thumbnailing is now broken, both in Opus and in Explorer. If I refresh the same folder in Explorer, most of the thumbnails vanish to be replaced with (if I'm lucky) the filetype icon, and otherwise with a blank area. Opening other folders in Explorer or Opus, whether their contents have been thumbnailed previously or not, produces the same effect: filetype icons and/or blanks. Opus and Explorer are now displaying the same thing: some files have thumbnails and some do not, and it's the same files in each program - Explorer seems to have 'forgotten' that it had a full set of thumbnails prior to Opus getting involved and now displays only the randomly-selected handful which Opus is showing me.

In Opus, this extends not only to thumbnails which should be generated by the Windows shell but also to thumbnails which Opus should be doing itself, such as JPGs, and also across all drives in the system - it is not confined to the one containing the folder where the problem first shows up. In Explorer, no new thumbnails will be generated for anything.

At this point, I usually find that Explorer itself is dead: it can't even enumerate the drives on my system, much less open folders. Control Panel is similarly broken - I just get a blank white window.

The only remedy now is a reboot - exiting Opus doesn't help. After this, everything works again - until I point Opus at a folder and set the view mode to Thumbnails...

The problem appears to be triggered specifically by putting Opus into a mode and folder where it must get thumbnails from the shell. Viewing the folder in, say, Power mode doesn't trigger the issue. Similarly if the folder contains only files which Opus can thumbnail itself, such as images, then there are no problems.

None of this was a problem under Windows 7, but I'm at a loss to explain what's going on here! To reiterate - this is a clean install of Windows with no additional software apart from Opus. No codec packs have been installed, and the only shell-extensions present are those which came from Windows and Opus.

The same problem shows up on my Surface tablet, running Windows 10 Pro build 1709 and Opus 12.7, so this isn't an isolated issue.

That sounds like the shell thumbnailer, or one of the demuxers or codecs it is calling, are crashing on one of the video files.

The Windows 10 demuxers have been found to do this by one or two people, although it doesn't seem to happen to everyone. My guess is files made by certain programs or in certain ways, or maybe corrupted in some way, trigger the problem, and the component isn't handling unexpected input gracefully (which is sadly a long-standing aspect of video software in general).

You can replace the Windows demuxer and/or codec with a third party one, which has worked for some people. I think I would first try to narrow it down to particular files in case they can simply be fixed (e.g. by remuxing the video, perhaps) or eliminated (if they aren't essential), since installing other codecs/demuxers can introduce other problems and might always leave you wondering if they're the issue next time something goes wrong.

If it's a fresh Windows install, make sure all the updates are installed before doing anything, in case they fix it.

Whatever it is will be outside of Opus, if the Movie plugin is disabled, since Opus won't be doing anything but asking Windows for a bitmap for each file in that situation.

Another thing to consider is antivirus may be blocking the thumbnailer. AV has a legitimate reason to inspect video files (e.g. exploits exist in subtitle data that can be used to run code), but that also opens the door for AV going wrong and messing things up.

As I said, there's nothing else installed - no codecs other than what came with Windows, no anti-virus, nothing.

Windows is fully uptodate.

The problem does not appear to be specific files - I've been testing this for hours, and as far as I can see it is completely random which files fail to produce thumbnails once Opus loads the folder. Plus, a crash on a particular file would not explain why files which have already been thumbnailed successfully no longer work once I run Opus :slight_smile:

A crash is the first thing I thought of but surely that would prevent thumbs working in Explorer as well? And again - why would a crash whilst generating a thumbnail result in a) no thumbnails working anywhere else in the system, and b) Explorer itself stopping working?

Regarding other codecs - I have now tried installing ffdshow (yeah, I know...!). It's definitely working - I can now see thumbs for files encoded with the FFV1 codec, for example, but it hasn't made any difference to the problem. I'll see if other codec packs get me anywhere.

One final thing: I tried setting the Movie plugin back to generating thumbs for itself. This works, insofar as it was able to generate them for MPG files, but it still went to the shell for .mp4 files with the same results as before. Can Opus handle H264 video itself?

Ah-ha :slight_smile: Installing the K-Lite pack seems to have solved the problem, presumably because it's replaced whatever buggy mess Windows is providing.

I'll keep testing, but so far all seems well.

I use Media Preview by BabelSoft instead of a full codec pack. The codec pack usually just has something like this in it anyway. Never had a missing thumbnail since installed. No idea if it works under 10, it hasn't been updated in a while.