SFTP doesn't work for me in DOpus 11.10.4 Beta


when I read in the announcement of version 11.10.4 Beta that the SFTP feature had been improved ("The Advanced FTP SSH support has been updated to improve compatibility with servers that only support the more modern encryption methods"), I was rather happy because SFTP in DOpus was really slow for me (see Slow SFTP Download Speed (Upload Speed is Fine)).

After installing the new Beta and rebooting the computer, I'm now completely unable to use SFTP with DOpus - the login doesn't work anymore. Here's the log from one of my attempts to log in:

[quote]Opening Connection mydomain.tld:22
Server version: SSH-2.0-OpenSSH_6.6p1-hpn14v4
Using SSH protocol version 2
We claim version: SSH-2.0-PuTTY_Local:_Jan_30_2015_13:48:04
Server supports delayed compression; will try this later
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Host key fingerprint is:
ssh-rsa 2048 73:b7:55:59:d9:27:4e:a1:fc:45:f4:0e:e5:07:2a:2d
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA-256 client->server MAC algorithm
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA-256 server->client MAC algorithm
Disconnected: Unable to authenticate
SSH: Unable to authenticate
Connection closed[/quote]
There's nothing wrong with the login credentials - they are saved in DOpus' FTP Address Book and have worked until yesterday. And it's possible to log into the accounts using WinSCP or ExpanDrive, so there's no problem with the server.

DOpus is able to log in using FTP instead of SFTP (with the same credentials - this is a special feature of my webhoster).

As offered in the other thread (see link above), I can provide you with a test account for the server, if you like.

Thanks in advance for your help!


Please email me (jon@gpsoft.com.au) the login details and I'll take a look.

Thank you very much for your help. I just sent you the login details.

BTW: Would it be possible to install version 11.10.3 over the current Beta or would I have to uninstall DOpus first?


Installing 11.10.3 over the top of 11.10.4 will work fine, if you need to go back to the previous beta.

Thank you very much for the information. For now, I'll stick with 11.10.4 - hopefully I can help to fix this.


Jon sent me a fix which works just fine, so this problem is solved. Even more, the new Beta he sent me is much, much faster, so I'm really happy now! :slight_smile:


Jon's on the job (as usual)!

I wanted to pop in and report the same problem. I have one account that requires SFTP to access, and I'm locked out of there with (If you need another test case, feel free to reach out.) Stepping back to Opus 11.10.3 fixed the issue for me.

Now that I've confirmed the cause of the problem, though, I'm going to step back up to 11.10.4 and just use another FTP client for that one account until the fix comes down the pike. :slight_smile:

If you'd like to try the test versions I sent to Enigma, you can download them here: 32-bit 64-bit

Please let us know if you still have the problem or if it fixes it for you as well.

Thanks for the links!

Unfortunately, .5511 doesn't fix my issue. :frowning:

I'm connecting via SFTP over port 22, non-anonymously (username/password), and using local time adjustment (as I do with all FTP sites in my address book).

Here's the error message I get when I connect:

And the one I get when I attempt to copy a file to the remote location:

I'll also send a note to the support address with the log. If you'd like, you're welcome to contact me back and remote in to have a look on my machine. Just reply and let me know.

Just to follow up for posterity: Team Opus fixed my issue, and things are working great in the latest public beta, (5522).