SFTP / FTP(S): can't download folders


currently I'm not able to download folders via SFTP or FTPS. I can download files (drag&drop or copy&paste in a dual display lister), and I can upload files and folders to the server via drag&drop, but when I try downloading folders, absolutely nothing happens. There isn't even a single entry in the FTP logs.

Using WinSCP, everything works fine. I tried different servers, but it made no difference.

I'm using Directory Opus Pro 12.9.2 (Beta) x64 right now. I'm not absolutely sure, but this might have started with version 12.9.1 (Beta). I haven't tried older versions yet - if somebody has a similar problem and had success with e.g. version 12.9.0, I'd use that for the time being. Unfortunately I'm quite busy at the moment and don't have the time for a lot of testing.

Maybe there is a setting I didn't find that might help? There are some in "Miscellaneous > Advanced", but judging from their names, they aren't involved here.

Thank you very much for any help!


If nothing happens at all, with not a single line in the FTP log, then my guess is you've modified the folder drag & drop events in some way which means nothing is happening when you drag them from SFTP/FTPS to the local filesystem.

What happens if you open a dual file display with the destination folder, then select a folder on the FTP site/side and click Copy Files to copy it that way? Does that work?

Hi Leo,

thank you very much for your help.

Copying to clipboard and pasting to the destination folder doesn't work, but clicking on "Copy Files" indeed does the trick.

I checked the events of the "All folders" file type, and all four "Drag-and-drop" events are not defined. Copying folders normally works when SFTP / FTP(S) isn't involved and even when uploading, so I didn't expect to find anything there.

I also searched the configuration, but without success. Could you tell me where else to search for such a setting? I really can't remember having modified the folder drag&drop events for FTP and have no clue where to search for an option to do so.


Ctrl-C / Ctrl-V hotkeys should be under Settings > Customize Toolbars > Keys.

Relevant Drag & Drop events should be under Settings > File Types > All Folders, or All Files and Folders.

One thing to check: Are the folders on the remote site appearing as folders in Opus? Sometimes it's ambiguous whether or something is a file or a folder (particularly if it's pointed to by a symlink).

Well, Ctrl + C is set to Copy ("Copy selected files and folders to the clipboard"), Ctrl + V is set to Paste ("Paste files and folders on the clipboard to the destination folder"). This works fine everywhere except when copying from SFTP / FTP(S), so this should be fine. Also, using the context menu's "Copy to clipboard" and "Paste" always works, but not here.

I already checked "Settings > File Types > All folders"; as I said, the drag&drop event handlers aren't defined (which means the default handlers should work). "Settings > File Types > All files and folders" has the following drag&drop handlers:

Drag-and-drop: copy movewhensame
Drag-and-drop + Alt: copy makeshortcut
Drag-and-drop + Ctrl: copy renamewhensame
Drag-and-drop + Shift: copy move

These should be the default handlers set by DOpus itself, and they work fine - except in this special case (and even there they work for files).

The remote folders do appear as folders (yellow folder icon); their type is listed as "File Folder". When I drag a folder to the destination folder, the tooltip even says "+ Copy to [destination folder name]", but when I drop it, nothing happens.

Really strange... :thinking:


Those events and commands look correct.

A quick test here shows it working OK for me on an SFTP site.

(When dragging folders from the file display. Dragging from the folder tree creates a .url shortcut to the folder instead. Copy & paste copies with both the file display and the folder tree.)

Do you have any clipboard monitor tools or similar that might be interfering with things? (They're less likely to affect drag & drop, but it's possible. The underlying APIs/objects used are quite similar for both clipboard and drag & drop.)

Yes, I'm using Ace Text (http://www.acetext.com/). I just shut it down, did the same with Directory Opus (right click on notification bar icon > Exit), then opened DOpus again and checked it. Nothing changed.

There should be no other program interfering with the clipboard.

A small detail I forgot to mention: Dragging and dropping files works, as I said. When I try to copy files and folders, not even the files are copied. Not sure if this makes a difference for you.

// Edit: Creating a shortcut via drag&drop the way you described works.


Could be a permission issue,
normally you can right click the files in the server and modify the permissions.

Permissions won't be a factor since the folder can be copied by the Copy Files button.

Correct; to make absolutely sure, I just took a closer look at a folder with permissions 755 (no subfolders, just one file in it with permissions 644) and tried to copy it, which didn't work.

Thanks for your help anyway!