SFTP not working, needs kill and restart

Hi there! o)

I'm tinkering with Linux a lot lately and since using SFTP is the most usual way to get file access to a Linux based computer, I tried the DO SFTP implementation a few times recently, but it seems broken somehow, especially when browsing the root filesystem "/".

DO will choke on "link" type of files like shown here in the WinSCP screenshot, the links at the bottom. DO will list them as folders and bring a requester which can be "OK"ed, but will always come back. It seems to loop on those links.

If you need more screenshots / log output of some kind, let me know. I try to avoid playing with it for now, since I need to exit / kill DO to get out of the error situation.

The SFTP endpoint I use is a simple OpenSSH server on a simple Debian v12.5 bookworm (stable) installation. Since I still don't know what I am doing on Linux, I did not touch a thing related to the OpenSSH server and its SFTP setting if there are any. o)

Maybe there is an easy way to get this repaired? Using FileZilla and WinSCP to access the Linux machines is quite cumbersome, using the Linux file managers with sftp://.. locations is even worse. Would be nice if DO could be used to make sense of all this SFTP stuff.. o)

Thank you! o)


Oh wait, I actually did change settings of the SSH server to allow "root" to login, since I need access to all the Linux files and system configurations spread around in /etc e.g.

(Lines below assume you are logged directly into the console of the Linux machine using user "root".)

I set..
PermitRootLogin YES

You can edit this config with..

nano /etc/ssh/sshd_config

Use CTRL+S to save and CTRL+X to exit "nano" editor.

Then reboot or restart the ssh-daemon..

systemctl restart sshd

Then connect / browse the SFTP connection to that server with DO at file system root ("/").

Following links should work, and does on the sites I have access to.

(At least for links that actually point to something valid. Some have problems with all clients, as they seem to point to dirs that don't exist on the server, or maybe don't allow access.)

Sometimes servers provide directory listings in a nonstandard format, which can confuse things. You can usually fix that by overriding the command used to generate the listings, but the exact details depend on the server.

Hu? What links? o)

I guess you have a lot of other things on your list, so if I can help by providing you access to an openssh-server for testing at any time, let me know. There's no need to rush things, somehow I will get along with the existing quirky tools out there.

We're about to start work replacing the (S)FTP code entirely, so if it's not urgent, I would wait until that is done. Chances are it'll fix this issue.

Ok, if the new code is better in general and more compatible.. then yes, why not! o)

I always switched back and forth to FileZilla whenever FTP was involved, it worked better for some reason in some situations. If the DO FTP got stuck, I always blamed it to the extra functionality within DO (viewer pane, extra columns, status bar codes etc.) and the ftp server being overwhelmed? Not sure though.

Maybe I have the "lab" ready by then, with various current FTP backends to test the new code against.

Looking forward! o)