SFTP too slow

I am using WinSSH from Bitwise on my server to use secure FTP to it. At home I am using latest Opus. The connection establishes OK, but the speed is like 50 KB/sec although my home connection is 10 Mbit and the server is on 1 Gbit line. Till yesterday I thought this is because of WinSSH, but they told me it has to be the client, Opus's "fault".

To test the claim I used their own SFTP client named Tunnelier. The download from my server is not 50 KB/sec and more but about 600 KB/sec which is more or less the normal speed I get without using SFTP but normal FTP (still some 20% slower though).

So I guess it is Opus implementation of SFTP that "throttles" the download speed. Is there any way you could fix this if it is broken or make some adjustements if necessary so I could use Opuses simplicity and quality for SFTP transfers?



Opus doesn't throttle download speeds unless configured to, which it isn't by default.

Are you using the latest version of Opus?

Are the two ssh clients using exactly the same settings, copying the same files, using the same number of connections?

No I do have set unlimited speed in opus (default).

I am using the latest Opus revision

Yes, same SFTP settings, copying same files, same time of the day, using 1 connection.

Have you tried some other SFTP clients with the server to see if they are the same speed as either Opus or Tunnelier?

e.g. FileZilla or WinSCP. (But make sure they are using the same setup, and in particular using SFTP and not SCP. SCP is quicker for some servers/devices, and is a different protocol to SFTP.)

No, I have tried just this two clients. I'll try one of your proposals (the one that is free I hope some is) and let you know.

Every other sFTP software I could try gives me speed of 8 MB/sek from my server, but Opus sFTP gives me 150 KB/sek :frowning: I find that unusable and unacceptable.


I have been having this issue for years with Dopus and always thought it was my host. Just switched to a VPS and I still had abysmal 50KBs/UP 140KBs/Down speeds. Did some investigating only to find that if I do not use DOPUS I get 250KBs/UP 2300KBs/Down. I get better speeds using sftp or scp with another app. Somthing is wrong with DOPUS in the way it handles SFTP data. I hope this gets looked at again and fixed.

May be unrelated, but I wouldn't be surprised if it was... Opus does not do multi-threaded uo/down-loads which results in slow speeds from some servers (and usually with all servers, with lots of smaller fiiles).

I don't know, but it works so slow I had to switch to other FTP client. Normal FTP is also so slow from my server, but it used to be fast years ago.

WinSCP which I am using now does not appear to be using a multi-threaded transfer, but it may and just not show an indication of it. In the end, I do not really care how the other apps achieve the faster speeds, I would just like DOPUS to achieve them as well. It is an absolutely stellar product but this poor sftp/scp support is a blemish on a near perfect product. This issue has been around a long time without being fixed, so I imagine not enough people have complained or possibly many are like me and assumed it was the servers fault. Either way I would like to know Leo's thoughts on the subject.

There's another thread on the wishlist talking about SCP support. One of the problems is that SFTP is a terrible protocol to being with. It sends unnecessary confirmation packets for each transfer packet, which makes the whole protocol dependent on the connection latency instead of the connection speed. It can never operate at anything close to the line speed.

SCP is a completely different protocol. When you are using WinSCP you are probably using SCP protocol and not really making a direct comparison to DOpus. That's not a defense of DOpus, just an explanation. Personally I think DOpus needs to get rid of SFTP and replace it with SCP+SSH. It would be both faster and more compatible since many SSH servers are not configured for SFTP.

For comparison, to the same server, DOpus SFTP gets 6.8 Mbit and SCP gets 160 Mbit. That's atrocious.