sFTP very slow

Yes, there are other topics on this issue, but no solution.

Yesterday I tried to copy a single, very large file over sFTP. DOpus (, 64bit) gave me a throughput of 300kB/s. Opened Filezilla, got the full bandwidth of my line - 1.3MB/s .

Any ideas?

How many connections is Filezilla using to send the file?

Is it using exactly the same protocol, port, etc.?

I just tried while limiting Filezilla to one connection, again it flooded my connection as high as it could.

Also, browsing the remote server with Filezilla is so much faster - it's a breeze, whereas with DOpus it's a very laborious provess (I had posted about this months ago)...

Anyone? Anyone? Bueller?

...noone? From what I understand this is a long-standing issue, weird that nobody seems to care?

There are so many factors involved, most of which (network, server, firewalls) we can't try at our end, making it difficult to say why Filezilla is faster than Opus at talking to the server.

Well, true enough and I appreciate that, BUT

-the fact that this is difficult to diagnose doesn't make it impossible. Not even an effort? Try to debug the thing? Nothing? Seriously, I'd be willing to let you use my PC remotely if it'd help...
-the fact that I've experienced this over three computers, multiple windows installations (ranging from XP to Win8) and through different ISPs suggest it's not such an isolated incident.

I very much like using DO for all my file needs, and this includes FTP as well (of course). But, if you're not concerned about such an important issue then I guess FTP support is provided by-the-way and I should not expect to rely on it...

What do you want us to try?

...try and fix it?

Don't know, I'm not a programmer, should I really reply to that question?

It's not that easy, unfortunately.

We can't fix a speed problem in Opus, or work around a speed problem in the server/network/firewall/hardware/drivers/etc., without being able to see it for ourselves and experiment with different changes.

In our own testing, when using identical settings, Opus performs about the same speed as other FTP clients.

Again, I understand. And again, I would expect a bit more effort. I;m guessing such problems arise all the time in much of the software world - something works for the dev, not so much for the user. That's why I said I could/would help as much as possible with drilling down.

As I said in a previous, similar thread, even browsing through the remote FS is much, much slower - each folder changing is painful while FileZilla does this without blinking an eye. I'm guessing this is not so much up to the network setup but rather how the program handles such requests.

Btw (no edit button?), my home setup is as plain as can be - no VPN, no firewalls, no nothing. The problem is there even though I've gone through four different routers.

It's probably best if you email us directly with details of your issue.

Ok then, will happily do :slight_smile:

You are not alone, I have asked for this to be looked at in the past.

Opus is simply pants at ftp.

I would LOVE to see this gets some much needed development attention.

[quote="Watoh"]You are not alone, I have asked for this to be looked at in the past.

Opus is simply pants at ftp.

I would LOVE to see this gets some much needed development attention.[/quote]

Yeah, I know, I've posted about it in the past and I've seen others' complaints. Going to send an email as requested in a few; support from the DO team has been fantastic in other regards, so I'm hopeful they'll get to the bottom of it...

Say, do you also have issues with normal (not secure) ftp? I don't even remember the last time I opened a normal FTP site so I can't say...

Seems like Iæm kinda slow to the this thread, but have anyone found out why the sftp is so slow? I have a 1000mbit connection between my main computer this one. And the max speed I can get is just below 10mbit. Using Winscp I get full steam ahead.

Yeah, I've verified speeds under different scenarios, DOpus is seriously lacking in this regards, to the point it's unusable for any sort of serious use... too bad.

I've used DOpus (S)FTP for ages and always thought the speeds were somewhat iffy, but continued anyway purely as I do everything else file-related in DOpus and it seemed simpler to continue rather than setup a separate FTP client and switch between the 2 whilst using the same set of files (primarily web development for me).

Alas.. I recently tried by FlashFXP and FileZilla.. and now wish I had a long time ago!

I started uploading a FreeBSD ISO to my local dev server as a test.. these are the results:

DOpus (


A very noticable difference.

The dev server is a FreeBSD 9.0 box (although this seems irrelevant looking at other posts as it doesn't seem to matter what the end destination hardware is) running over SSH 2. I've tried modifying the buffers as-per other posts on the forum and this has yielded no changing results.

Personally I believe that as this has been mentioned multiple times from multiple people using multiple different setups, that there is an underlying issue, but what that may be, I don't know.. but it does seem that dedicated FTP clients seem to give very similar results (eg: FlashFXP and FileZilla on my system return comparable results).. so if different FTP clients can manage this, surely DOpus can too?

I'd love to continue to work with DOpus as my only file-related software, but with the current SFTP performance, this is unfortunately (now that I've seen better performance) not possible :frowning:



Thanks for confirming it... it's a real shame IMO because, just like you, I'd like to use DO for all my file-related operations. And since DO has support for (s)FTP, why on earth would it be the neglected child? And, nowadays, using FTP is quite common.

You're lucky you had to upload a 2.2GB file; DO is also very slow processing each command, so imagine my position: I regularly take backups of my web site, which is now 43GB big and has 255k files. Even skipping identical ones, it'd take days for DO to complete a backup, whereas any free sFTP program takes an hour or so.

I was told the problem was because it's based on an old open-source sFTP program but, to be completely frank, I don't care much for it; DO is way up there in the file-management category, nothing else comes even close to it, so I'd expect it to at least be able to have similar performance with amateur projects on Sourceforge.

Same boat, same story.

Just adding my request again for some love to be shown for ftp in Opus.

I also backup websites with 1000s of files.. Opus is simply not up for the game. Its a shame.

Please Opus team update the ftp system in a future build.