Show seconds in time columns conflicts with custom_time_format

The advanced option custom_time_format causes the normal preference options Folders > Folder Display > Show seconds in time columns and Show milliseconds to behave unexpectedly.

My custom_time_format is set to H:mm.

When enabling the Seconds option in this scenario, there is no evidence of something potentially going wrong (but there may be). However, upon enabling the Milliseconds option, the Modified and Created columns show the appended .### ms appearing and disappearing with every few clicks inside the File Display. It's like Opus can't decide which preference to honour.

I thought it may because the normal and advanced options are out of alignment, meaning, my advance option's definition excludes ms, but on reading the help, I see no way to define ms anyway.

That leads me to believe there is a bigger problem than poor user configuration. I'd suggest disabling the s and ms options when an advanced time format has be defined, but that would mean "advanced" users wouldn't be able to have ms displayed (unless this time token is implemented).

At minimum, a note in the online help would be appreciated to explain what's going on.


System information:

- Directory Opus v12.23.2 Beta x64 Build 7734
- Windows 10 v20H2 OS Build 19042.868

Thanks! Fixed in the next update.

1 Like