Single DOpus Lister

Ok, once more the question:
Is it possible to configure DOpus so that only a single Lister is shown and all new directories/archives/folders are opened in a new tab?

I read several other threads around this topic and used the suggestions from Leo posted here: Always re-use a single window instead of opening new windows.
This works well for most use cases but unfortunately not for all.
When I open an archive from an email in Outlook, DOpus still opens a new lister and does not reuse the existing one. Can I change this behaviour?

I'm using Win 7 Pro, DOpus 11.15 and Outlook 2010.


What happens when you double click a zip archive on your desktop?

Good one - when I double an archive on the desktop, DOpus also opens a new lister. When I double click a folder a new tab in the existing lister is opened or when I double click on the desktop itself the previous lister is shown/

Try turning off Preferences / Zip & Other Archives / Zip Files / Make Opus the system default handler for Zip files, then click OK. Wait 10 seconds, then go back in and turn it back on and click OK.

That will make Opus re-write its registry settings for zip files.

If that doesn't work, the registry settings may be overridden e.g. via the Open With mechanism. Please run FileTypeDiag on the .zip extension and zip & attach the results, which should tell us what needs fixing in the registry.

Thanks leo,

I disabled the setting (and click OK to exit the settings), waited 5min, enabled the setting and click OK. Waited 2 more min before I tested the ZIP file handling but still the same behaviour.

Please find the output of FileTypeDiag for ".zip" attached. (19.2 KB)

Is Preferences / Launching Opus / Explorer Replacement / Open external folders in a new tab definitely turned on there?

HKCR\OpusZip\shell\open\command: "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /cmd go "%1" existinglister new

That's the registry setting which I'd expect to see when Open external folders in a new tab is off. When it is on, the setting should be:

HKCR\OpusZip\shell\open\command: "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /cmd go "%1" existinglister newtab=tofront

1 Like

Weird - but definitely YES

Anyway - I changed (after I took the screenshot above) the setting in the registry to the expected value and now everything works perfectly.

Many thanks!! :thumbsup: