Slow File Transfers Across Network

Hi.

I have found that on one of my computers that I have very slow file transfers across network folders using Directory Opus. If I use File Explorer, the process is at least 3 or 4 times faster.

I don't do many file transfers on other computers, so it may not be limited to just the one, which is the one I usually transfer to.

It has an Intel 82579v Gigabit Network Adapter

See:


Make sure your network card drivers are the proper ones for the hardware and up to date, as well, at both ends. Windows sometimes installs poor drivers, and also recently has a tendency to replace good drivers with poor ones on larger Windows updates.

At least one person got a huge perf uplift from that. The buffer sizes are also worth a try, as per the previous post.

Antivirus and lots of other things outside of Opus also play a part here, so you may need to diagnose the problem 9j your setup to better see where the issue is.

Hi Leo.
I can't notice any difference.

Hi b-s-ger. You have a similar problem?

Which things did you try?

The Buffer Size.

The NIC driver hasn't been updated yet, as Windows says it is the latest (2016), and Intel doesn't have a later Windows 10 64-bit driver, but it has a 2019 Windows 8/8.1 one.

If it was a NIC driver issue, do you think it would also be slow with File Explorer?

Yes I had. The buffer change mitigated the problem. But, I ordered some 10G equipment, let's see if Dopus can deal with it.

How high did you set the buffer?

Did you bother to read the posts I referred to?
500 MB.

Not necessarily. File Explorer is the one thing everyone tests with, and which is easy to measure speed in, so people tend to notice/complain if something makes Explorer slow. But if something is slow in Opus, it's probably going to be slow in almost everything else as well, e.g. saving documents to the network in Photoshop and so on. (Outside of things which simply call into the same basic file-copy API in the shell which File Explorer uses. You can do that from Opus if you need to, but you lose a lot of functionality.)

Sorry. I didn't mean to upset you. But you are talking about 500 MB buffer, and my defaults are only 512 KB.
That's a massive difference to the default setting.

I'm not upset. Yes, I have 500 MB. It's a mitigation. Not a solution. I will have 10G in about two weeks and see if it still works as a workaround.