[Solved] Rename doesn't work on external drive with exFAT format

I've tried to capitalize name file. The preview works fine, but after apply nothing has changed.
The files are on a external drive, exFAT.
If I copy this file on my local drive, renaming works.
Any ideas ?

Dopus 12.29X64 standard and portable version.

It’s a bug in Windows and exFAT. You’ll see the same in File Explorer and everything else.

Been that way for as long as I can remember, never fixed by Microsoft.

If you add a character it will work, and you can then remove it via a second rename.

I do what Leo suggested.
This bug drives me crazy - but I don't use exFAT drives, only NTFS.
I think this happens more when I am working with files on a Mac formatted HFSJ drive (not case-sensitive). I use MacDrive, so I can work with those drives but much prefer to move the files gathered from Macs to an NTFS drive.

The Windows bug doesn't affect NTFS, but might affect other Windows filesystem drivers with the same bug as the exFAT one.

exFAT is the only one I've encountered with the bug personally, but I've not tried with MacDrive's HFSJ.