Some FLV not playing


Most FLV files are fine, but recently some FLV files don't play in the viewer pane. They are just a jumble of letters and no thumbnail. The files themselves play OK in other players.

Am on the latest dopus downloaded today.

As it is a recent problem, could I be missing a new type codec?

See the FAQ on video playback.

You probably need a newer FLV splitter.

If you're using 64-bit Opus then you need to get a 64-bit FLV splitter.

Sorry, am a bit stuck now.

I have downloaded latest FFDShow and also those splitters.

I am a bit confused on regsvr32.exe. it was not in the splitters folder. Found regsvr32a.exe on Microsoft. It created regsvr32.exe in the folder, but when I double click that (or use run command) I get an error message 'no dll name specified'

Any clues? I know it's not an opus issue.

You have to use regsvr32 from the command prompt (and on Vista / Win 7 it needs to be an admin command prompt).

The command will be in your path already; just open the prompt, CD to the location of the splitter file, and type regsvr32.exe .

There's a toolbar button here which you can use to run regsvr32.exe (with UAC elevation on Vista/7 as required), if it helps:

[Register or Unregister DLL or OCX)

MSDOS command prompts? I've heard of that I think!

Will the button work on XP by the way?

Thanks for help. I'll read up on command prompts and stuff and give it a go.

Yep, the button will work on XP.

Button works great

Success of sorts. About half the troublesome FLV's now play in WMP, but still no luck in Dopus.

I used the splitter from first pack listed in the FAQ, but it caused a runtime error when opening Dopus with troublesome FLV's in it. Restored system and used the alternative instead.

Installed latest FFDshow, so at moment, still some FLV's won't play in opus, and some of those, but not all, will successfully play in WMP.

Presumably you're using 32-bit XP, not 64-bit? (Things are more complicated on 64-bit.)

FWIW, I've long found FLV playback finicky. Though I seem to have it working fairly well at the moment, sometimes I come across an FLV file that won't play with my current splitters and I have to update them. (I've also found situations where one splitter only works with some files and another only works with others.)

But if you have them working in WMP then it's definitely odd that they don't work in Opus as well (unless you're on 64-bit)...

am on 32 bit XP, service pack 3

However, I tried it all again and cleaned things out first. All now play except for one that plays in 'VLC media player', but not WMP.

The trouble one is a newer file, so maybe a newer codec is coming along?

Thanks for the help.

The problem codec seems to be the AVC1 codec, alos used on mp4's which also don;t play in opus.

ffdshow supports it apparently.

Can it be got separately and installed without messing things up.

Depends which AVC1 codec you're talking about.

I only install FFDShow + some MPC splitters myself, on top of whatever comes with the OS. I've found installing too many codecs leads to a world of pain as they conflict with each other. (Anything that the latest FFDShow + MPC splitters won't play I use VLC for. If VLC doesn't work I try GOM. If that doesn't work I delete the file and curse whoever made it. :slight_smile: )

You're probably better off looking for help in a forum dedicated to video software for anything more complex than what's in the video FAQ here. People there may know the particulars of different codecs/versions and how to get them to coexist if need be.