Some Problems with WinRAR in DOpus_v9.1.3.0

Problem 1:
[ul]In previous version of DOpus, the following code was worked without any problem:

@runonce: {apppath|WinRAR.exe}winrar.exe A -as -s- -rr3% -t -u -o+ -m5 -ep1 -r "{d}{file$|noext}.rar" {F!}

but in new version (, every time I select more than 32 files or directory in source pane, I receive an error message that say [b]"Windows cannot access the specified device, path or file. You may not have the appropriate to access the item"[/b] (The pic).

This problem is appeared in following code too:

doptest.exe {apppath|WinRAR.exe}winrar.exe A -as -s- -rr3% -t -u -o+ -m5 -ep1 -r "{d}{file$|noext}.rar" {F!}

[/ul][b]Problem 2 (Was solved, just for notofication):[/b]
[ul]In new version, every time I double click on a RAR file, I receive an error message that say [b]"Cannot open .rar"[/b]. I deleted "C:\Program Files\WinRAR\WinRAR.exe" "%1" from "Settings -> System file types -> RAR -> Events -> Left-double click" and the problem was solved. This problem was not appeared in previous version too.[/ul]


Problem 1:

Sounds like you're just running into the command-line length limit in Windows. You can check if that is true by going to a shorter directory, with shorter filenames inside of it, and seeing if the command works for more than 32 files in there.

Problem 2:

Confirmed & reported. Seems to only happen if you've assigned something to the RAR filetype's Left Double-Click event. Other types seem fine, as do buttons which run on RAR files.

Do you know which version it used to work in? That might help track down what has changed. If you've upgraded to in the last couple of days I'm guessing you skipped a few versions before that.

Thanks to reply dear Leo.

[quote="leo"]Problem 1:

Sounds like you're just running into the command-line length limit in Windows.(...)[/quote]

But my path is the same, my files are the same, my WinRAR is the same and my code is the same. Just my DOpus version is changed!

Problem 2:

I was upgraded from to There is no problem in

Best Regards

Change the command type to MS-DOS, put an "echo" before the winrar command line, and add a "pause" line at the bottom. What's the command line which Opus is generating when you select those files?

Sorry for my delay! My HDD was died and I was restoring my data.

I cannot understand what was happened, but now, v9.1.1.8 and v9.1.3.0 have the same error!.

But a question out of DOpus, I hope you help me again as always:
When I compress my files by WinRAR right-click context menu, why the number of selected files are not matter? What happened for passed command line when context menu is used?


WinRAR probably uses a shell extension to add its context menu items. Those pass the list of filenames via COM and don't use the command-line to run things at all.