SSH Login via certificate

How do I get Dopus to login to my dd-wrt router via ssh? I have tried but haven't had any luck. I upgraded to adv ftp because I thought it would allow me to ssh without having to use putty. I use pageant to pass the cert.

See the FAQ.

Yea I guess I was dumb, I read it but didn't quite grasp it.

I have tried everything and cannot get it to login. Putty login works fine, but not with dopus. I must be missing something or the program is not able to do what I require. Please see attached and instruct me as to what I can change please.

The FAQ is very uninformative in relation to the issue I have. I wouldn't of reached out to support if the "facts" helped.

When it doesn't work, what goes wrong?

What does the FTP log say?

See attached below for error, thanks for trying to help.

Here you see putty using same ssh-rsa key and it working.

That created a Shell - DOpus doesn't support a shell, does it?

Well is this possible with DOpus?

I'm not sure where it is going wrong, to be honest.

The log screenshot shows the key (well, a key at least) is being tried ("Trying Pageant key #0") but then that the server rejects it ("Key refused").

Assuming the same username, server, port, protocol and key are being used in both cases, I don't know why the server would reject the key with Opus and accept it with PuTTY.

You and I both my friend, perplexes me as well.