Strange I/O network error


I found a possible strange bug/Issue with DOpus related to network.

from time to time i get an network i/o error when reading files from NAS in a 3rd party application not in DOpus, but the error seems to be generated when i'm browsing file structure on NAS in DOpus.

i tried to recreate the error and browsing/moving files in Total commander for example but that seems fine or i haven't been able to recreate it.

seems to happen when dopus is parsing network folder / subfolder
perhaps some network / thread overload is happening in Windows ?

i'm running on 10Gbit network

is it possible to install an earlier version of DOpus from a few months back, i tried an installer for an earlier verson but only got latest version during install.


Opus looking at a folder could not cause problems for other software unless there's a problem with the device or drivers (or network in between etc.)

The issue will be something outside of Opus.

(Also, Opus does not talk to any device directly. Everything happens through standard Windows APIs at a high level.)

Try searching for the error message and/or number and the make and/or model of NAS. You'll often find other people with the same problem. Also check for updates to the NAS software/firmware. Failing that, report the issue to the NAS vendor.