Strange issue with dates in FTP (Opus & FileZilla)

Yesterday I noticed that when uploading a file via FTP the "last Modified" date showing in the remote server panel was not 31.12.2020 as expected, but 01.01.2020, though the time part was correct.

This morning I see that those same files are showing today's date (01.01.2021) and still the correct time part;

And today's files are showing the correct date and time.

Strangely, earlier files show the correct date but all times are set to 00:00

The time parts aside, the only explanation I can think of is that the program is using a DayOfYear function and not taking into account the Leap Year - hence day 366 mod 365 - 1 - 01.01.2020. (This doesn't explain why earlier times are set to 00:00 though.)

The times and dates on the server itself (if I log via remote desktop) are correct, as are the system date/time on both my machine and the server.

I am not the only seeing this - I've checked with two colleagues and they see it too - and they're using Filezilla, so this may be a Windows bug rather than an Opus one. But has anyone else seen this, and have an explanation?

Since it happens in FileZilla as well, it seems more likely it's an issue with the server rather than both Opus and FileZilla. It probably doesn't report the times properly via FTP.

I'm experiencing this issue on three different servers! Still, as Filezilla also sees it, I expect it's either a Windows bug or maybe something within the FTP protocol itself - maybe even a side-effect of some y2k fix...

.. are you not seeing the same issue? Two other people I've spoken to can...

Are all the servers running the same software?

Have you checked what the FTP server is returning when you do a directory listing, e.g. using a command-line FTP client?

Sounds like the server shows ISO year instead of calendar year.

Looking on the server(s) directly (via Remote Desktop) all dates and times are correct. I haven't tried a CLI client (I'll have to brush up on the commands), but the CoreFTP client application was showing correct dates and times yesterday, but today is showing all times as 00:00 even though the dates are still correct!

It's all very strange. Whatever it is, it isn't just Opus - but it isn't just a particular server issuer either - I'm seeing this on 3 different servers, all hosted with different companies.

If you can remote desktop to the servers, presumably they're also all running the same FTP server software (there aren't that many Windows FTP servers)? Given the problem is happening with three FTP clients now, and I can't find anything about a general FTP issue affecting 2021 file dates via a web search, I'd say you need to look at the FTP server software. Not the dates in the filesystem but the dates the FTP server is reporting.

Yes, that is a possibility I hadn'.t thought of - you're right, they do all run the same FTP server s/w. I'll pursue that line of enquiry. Thanks - and apologies for any unintended slur upon Directory Opus, which I really like and value!
Have a great New Year - 2021 has one job: to be better than 2020...

fyi, just tried using the command prompt, as you suggested, and getting the same issue - so yes, I guess the problem lies with the FTP server s/w used. Thanks for your time.

1 Like