Support for FTP's CHMTIME command

Directory Opus' FTP is not automatically setting or allowing changes to the modification times of files on my FTP server, something I was able to do with Filezilla. It seems Filezilla is using the CHMTIME FTP command, which my FTP server supports, but Directory Opus apparently doesn't.

In future versions, I'd really like to have Directory Opus consider using that command if other ways of setting mtime are not available.

Should I send this request straight to support? If so, how do I do that?


Are we talking about FTP or SFTP?

CHMTIME is typically only used by SFTP clients/servers, as far as I can tell. (And Opus is able to change times on my SFTP server, although I am not sure which command it is using off the top of my head.)

If it is an FTP server, which server software is it running?

You just need to link your account and then posts to the forum are considered support requests where appropriate.

Hi leo, thanks for your reply. It's regular FTP, the server software is Pure-FTPd, version 1.0.30. Does your Directory Opus allow you to change the timestamp of existing files on your SFTP server? I think mine can't because "Set file date to:" is always disabled under Set Attributes when right clicking on any file on the FTP server.

When I upload, even with COPYFILETIMES=yes COPYDIRTIMES=yes COPYCREATIONTIME=yes, it always sets the destination file's timestamp to the time of the transfer. I tried messing with the Site Properties, under the Misc tab, setting the MDTM field to other values, but it doesn't seem to make any difference.

Here's the list of the server's supported extensions:
211-Extensions supported:
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;

Hope this helps.

AFAIK there's no such generic CHMTIME command as such for any FTP server and it's not part of the standard FTP command sets. It's a special command name used in FileZilla.

There are mechanisms to support setting remote file dates on some servers, and these are supported by Opus 10, but many servers are dumb and do not allow this. ServU was one of the first to permit setting remote file/folder dates with a modification of the MDTM command (which 'normally' only is used to read a file time no set one).

The correct supported method is to use the MFxx commands such as MFMT/MFCT (for example as described in Command Extensions for FTP draft-somers-ftp-mfxx-04). If a server supports this then the must indicate this by the response to the FEAT(ures) enquiry response.

I did a couple of quick checks and it seems that the later PureFTPds do support this but the server above does not, or it is not implemented. There's no indication of support for this in the FEAT response above.

For further support you will need to link your account to the forum and maybe able to help you further. You'll also need to upgrade to Opus 10 (unless your profile info on the side just needs updating; it says you're using Opus 9).

Problem solved. More precisely, there wasn't a problem, I was trying to solve this on behalf of my brother. After failing many times to reproduce Filezilla's ability to set timestamps on an FTP connection to that server (it can't), only then he informed me it was connecting through SFTP :unamused: Directory Opus is working as it should if I connect through SFTP.

Greg and leo, I really appreciate your support and apologize for wasting your precious time on this non-existing problem.

Btw, Filezilla was apparently using MDTM even though it displayed chmtime on its "Message log", I was assuming that was an actual FTP command.

Thank you very much.

No problem! Easy mistake to make. :slight_smile:

Yes, it looks like FileZilla's log is slightly abstracted from the real commands being sent, maybe to give a consistent view across different types of sites/connections.