Switching Toolbars Causes "Program Not Responding"

Hello all. I have been a registered user of Directory Opus for many years now, and it has always served me well. It is, IMHO, one of the most fantastic programs out there. It's always the 1st program I install when doing a new OS installation. However, lately ( the last couple of months ), I have been getting a strange behavior from Dopus when I want to change toolbars. I have had my toolbars set up for many years now, and just use them for starting programs, rather than clutter my desktop with icons. I only have 9 toolbars in total that I use, but only one shows at a time. What happens lately is that when I click on a icon that closes the current toolbar, and opens another toolbar in it's place, it takes about 10 seconds for the change to happen, when it used to happen almost immediately. During those 10 seconds, up at the top in the program's title bar, I get the message that the "Program Has Stopped Responding". I just patiently wait for the 10 seconds or so, and then the wanted toolbar finally shows up, and the 'stopped responding' notification goes away.

All the icons I use in my toolbars point to programs that are on my C: drive. None of them point to network drives, nor does my C: drive spin down, as it is a SSD. Taking that into consideration, the change in toolbars should be very fast, considering I'm using a Solid State Drive as my C: drive, and Dopus is also installed on the C: drive, of course.

The icons I use to switch toolbars are configured as follows:

I have a Main Programs toolbar that contains icons to the other toolbars I have created for groups of programs such as Graphics, Audio, General Apps, etc...
The icons pointing to those toolbars are configured as follows:

Function: Standard Function (Opus or external)
Then down below are the actual commands, in the form of:

Toolbar "Main Programs" close
Toolbar "Graphics" LINE 2

So, if anyone has any ideas as to why it takes so long to switch toolbars now, please feel free to guide me in the right direction. Maybe the commands have changed over the years, but I could not find anything in the help files that indicates that. Leo, would you have any idea why this has been happening lately? The only thing that is odd is that once I have switched to another toolbar, and it takes that 10 seconds, when I switch back to my "Main Programs" toolbar, and then click on the "Graphics" icon a second time, the program does what it should, that is to change toolbars almost immediately, and I do not get a "not responding" notification. I have plenty of memory, 8GBs worth, and from my memory program indicator, most of the time I have 5GBs free to use, so I don't believe it's a matter of the system having to use the pagefile. I also have PreFetch turned on, and I'm using Windows 8.1 Update 1 with all current updates applied, a 64 bit CPU running at 3.7Mhz, so I also don't believe my problem is related to any hardware I use.

Any help would be greatly appreciated!!!


If you're familiar with Process Monitor, that will probably reveal what's going on during the delay.

If not, you could zip up your /dopusdata/Buttons folder and upload it for us to take a look at what's on the toolbar.

Another thing to try is disabling antivirus scanning, in case loading icons for the toolbars out of exe/dll files is what's taking so much time, which could happen if an AV scanner keeps wanting to re-scan the files and takes a very long time to do so for some reason.

Hello, leo, hope all is going well with you!

Process Monitor was my 1st 'go-to' app to see if I could find out the cause for the delay, but it does not reveal anything that sets off any red flags for me.

However, a curious thing. I do not have a '/dopusdata/' folder. The 'Button' folder on my system is located in '{user}/AppData/Roaming/GPSoftware/Directory Opus/Buttons/' . Could that be the problem? Do I need to create a 'dopusdata' folder to put the 'Buttons' folder into?

As far as antivirus, I find that Windows Defender is more than capable of protecting my system, along with the strong extensions I run with my web browser. I've never gotten a 'nasty' yet, using common sense and good extensions for protection. However, just for a test, I whitelisted the 'Directory Opus' folder, and ran the program again, with the same results.

I appreciate the suggestions, but I don't know how comfortable I am posting my Buttons folder, which is basically a list of all the programs I run/have on my system. I might not want the world to know that I play the game "My little pony", for example.... LOL I don't, but you get the idea??

Is there any other way to resolve this, without posting my Buttons folder?

Once again, many thanks!

/dopusdata is a folder alias which, if typed into Opus, should resolve to the same path you mentioned.

If you want to zip the buttons folder and send it to me privately, I can take a look at it without the details going to the forum, if that's any use? leo@gpsoft.com.au

Done, and thanks for the time and effort spent!!


If you remove the two drive drop-downs, does it still happen? I'm not sure but it's possible they could cause a delay if a drive takes a long time to respond. (e.g. Because it has spun down, or is not accessible.)

If it's not the drive drop-downs, it might make sense to remove a few items at a time until it stops happening, to narrow down which item(s) are causing the delay.

I can't see anything obviously wrong in the Main Programs toolbar, and I'm able to click the buttons on that to toggle to the other toolbars & back without delays on my test system. (But, of course, I don't have a lot of the software installed, so a lot of those icons aren't being loaded; just placeholders instead.)

If it turns out to be due to loading lots of icons from external EXEs/DLLs (which can take a few seconds on the first load, in a worst-case scenario), that can be worked around by creating an icon set for them. Please try the other things first, though, as they should give us an indication if it's just the icons as well (as the delay will get less and less, proportional to the number of icons, instead of one particular icon being responsible for the whole delay, as may also be the case).

I will do as you say, and report back with my findings when I finish. But actually, this really doesn't make any sense to me, seeing as how I've had Dopus set up this way for a while now, but the delay in switching toolbars just started happening a couple of weeks ago.

However, you are one of the developers, and I'm only a long time user, so I'll take your advice and see what comes of it.

Thanks again, and I'll update asap.


Also, please remember I'm using a very fast SSD, so I don't think that loading the external EXEs/DLLs is going to take a few seconds. My entire system boots in 4 seconds, so I cannot begin to fathom why it would take 10 secs to load a few icons. But as I said, I'll post back with results asap.


OK, I removed the icons from the 'System' toolbar, one by one, then did a restart of the system, fired up Dopus, and get the same result. Why do you think I'm getting a 'Not Responding' message up in the title bar when it takes those 8-10 seconds to switch toolbars??

I even gave thought to making a RAM disk, and installing Dopus there, but after some thought, I believe it would run even slower, because it would be RAM based, which is slower than the speed of my SSD, so it wouldn't make sense to even run this great program from a RAM disk, in my case.

So, I've got everything back to the way it was before I posted, and I suppose I'll just live with it. A small price to pay, in order to utilize such a useful and faithful program that I've relied upon for years and years.

And the 10 second delay only happens the first time I switch toolbars. After that, the toolbars switch almost instantly (which shows me they are being stored in memory somehow), so I really only have to put up with the delay once for each toolbar, until my next system reboot. As I say, well worth the wait, for I will never stop using this powerful program!!


Did you just remove the icons, or the whole buttons?

It could be the commands the buttons run, not just the icons, FWIW. The ones pointing to Control Panel items (with IDL?:... paths) might be worth removing first to see if it's them.

I did say that I removed the icons, but I actually meant I deleted the buttons. I would delete one button from the System toolbar, reboot, and give it a try. I did that, one by one, with no improvement.

I don't have any Control Panel items/buttons on my System toolbar. Those are on the Main Programs toolbar, which shows by default as my startup toolbar, when Dopus first starts. I consider that toolbar as sort of a command center, whereby I can access all the other toolbars, System, Graphics, Games, Apps, etc...

So, I'm not even clicking on a Control Panel button when the delays happen. Just clicking on one of the buttons that will close the Main Programs toolbar, and open one of the other toolbars in it's place. As you saw in your test, when you click on the Games button from the Main Programs toolbar, the result is that you will then only see one toolbar that contains buttons for my installed games. I have a Back Arrow on each toolbar, that when clicked, closes the current toolbar, in this case Games, and re-opens the default Main Programs toolbar.

The thing that concerns me more than anything is why the program reports "Not Responding" in the title bar during the 10 sec delay. Dopus has never done that in all the years I've used it. You've seen my button configurations, and know them to be correct. I believe the problem resides elsewhere, but then I seem to be the only person with this particular issue, so I can't say it's a coding issue.

Have you heard of any reports of the "Not Responding" notification??

"Not Responding" means the window has stopped processing messages, because the UI thread responsible for it is busy doing something or has hung waiting for a system call to return. As soon as the thread starts processing messages again the "Not Responding" message will go away.

"Not Responding" is a symptom, not the cause, and the question is what's causing the UI thread to stop processing messages for so long.

Hello, jon. I can understand your explanation, and it makes sense to me. You are correct in asking what's causing the UI thread to stop processing messages for so long, but so far, it's beyond my ability to track down a cause. As you can see in the thread, I've disabled Windows Defender, I've removed buttons on the toolbar, and I even deleted the dopus Prefetch data (which of course was rebuilt again), all to no avail. I do not believe it to be a virus type issue, as I do a malware scan, an adware scan, and a rootkit scan 3 time a week with separate dedicated programs. I also have very strong extensions installed in my browser to help guard against infection of any sort.

As I say, I'm at a total loss as to how I can rid Opus of the 'symptom'........

So this delay happens when you change from one toolbar to another, even if both toolbars are completely blank?

That scenario I have not tried. I will create two toolbars, one with only 1 button, in order to switch to the second toolbar that will be completely blank, except for the back arrow, to return to the 1st toolbar.

I'll post back with the results.

Alright. I made the two new toolbars that were as described above, rebooted, started Opus, and switched between the two new toolbars without a problem, nor without a delay.

So, please correct me if I'm wrong here, but one of two things has to be happening. Either I have too many program buttons on my toolbars, and that is slowing the program down, which would mean there is a finite limit to the number of program icons I can put on any toolbar, even though they don't come close to extending across the entire toolbar.

Second thing that could be happening is that some of the icons that come from the actual program I have installed, and want to run, are slowing down the Opus program when it has to go out and fetch them.

Would I be close to correct in the above statements??

It's probably something like that, and the way to narrow it down is to progressively add back the buttons until you find the one that causes it.

On each and every toolbar that I have created and used for years? I don't understand how one button/icon could cause all of my toolbars to load very slowly the first time only. I'm not a programmer, but something just doesn't make sense to me about that.

IF the only option is to do that, then I suppose I'll work on it over the next few days, and let you know the results.

Many thanks for trying to help. I appreciate the time and effort involved, I know that both you and leo are busy fellows.


You don't have to do it on each and every toolbar. Just on a pair that exhibit the problem, then toggle between the two of them without loading any other toolbars.

If you do not load the other toolbars, then what is or isn't on them does not matter. (Unless "always enable this toolbar's keys in listers" is turned on for the toolbar, since that will cause it to be loaded and just not visible.)

[quote="leo"]You don't have to do it on each and every toolbar. Just on a pair that exhibit the problem, then toggle between the two of them without loading any other toolbars.

If you do not load the other toolbars, then what is or isn't on them does not matter. (Unless "always enable this toolbar's keys in listers" is turned on for the toolbar, since that will cause it to be loaded and just not visible.)[/quote]

I gain access to my custom toolbars from on main toolbar, the one named "Main Programs". You could think of it as an index to my other toolbars. I use most of my toolbars on a daily basis, because as I said, I do not have any icons on my desktop, because I rely upon Opus to launch any installed program I have, by switching to the appropriate toolbar, then clicking on the button for the program I want to run.

This delay happens between my Main Program toolbar, and ALL the other toolbars I have created, but just for the first time I make the switch to a particular toolbar. For example, I boot my computer, I start Opus, and from the Main Programs toolbar I choose to switch to the CD toolbar. I get the 8-10 second delay, the 'Not Responding' message, and then the CD toolbar shows up. I can then switch back to my Main Programs toolbar, and for the rest of the day, if I want to bring up the CD toolbar, it comes up almost at once. The same thing applies to the other toolbars I use, which I sent you.

If I want to run a malware scanner, for example, I will switch from my Main Programs toolbar to the 'System' toolbar. 1st time I switch, I get the delay and the message. After that, whenever I want to switch to 'System' toolbar, it does so almost at once without delay or message. This applies to all the custom toolbars that I use, same behavior for each toolbar.

I have been using the same toolbars for a very long time, the only thing that usually changes is that the programs I have installed on my system get updated, but that doesn't affect the button I have made for the programs. The reason is that my method of adding a button on a custom toolbar is to navigate to the installed programs' folder, switch to the toolbar I want that program on, then click 'Customize' on that toolbar, and then from the lister I drag and drop the .exe of the program I want to use up to the toolbar. Simple, easy, and always reliable.

It's just these last few weeks that I get the long delay in switching toolbars, and the message, only for the first time I switch to ANY given toolbar, all of them. It's not just one pair that is causing the behavior, it's any combination, on the very first switch.

As for the setting of "always enable this toolbar's keys in listers", I have that setting enabled for all my custom toolbars. Perhaps that is a problem, but again, why all the sudden, after all these years??

Anyways, I'll turn off that setting, and see if it makes a difference.

Thanks again for hanging in there with me. If we are able to solve this, I assure you it will be an interesting find.... :sunglasses: