Synchronization upload fails

So, what is the problem Jon ?

Are you sending the files over FTP in ASCII mode instead of binary?

Or are the files being modified in any way on the source or destination side after the sync?

Something is causing the file sizes to be different, which will mean the files are re-synched.

Automatic - as per image I sent.

Was set to Binary - tried Automatic again - file size not the same - changed back to binary - date time same size different either weay - that is afgter closing and resatarting Directory Opus each time !

If you have it set to binary and the file sizes are changing, something is seriously wrong with the FTP server and I wouldn't trust it for backup at all.

Hi Jon,
I don't use it for backup, I use it to upload files, i.e. update and synchronize from my local folder to the server both obviously have the same start-up folder and subfolder structure.
The update is from my local to the server. These are then used to support my remote connection service.
Additionally, from the Chicago Illinois server the files are then synchronised to my Server in Nuremberg DE which supports my Toolbox in the ScreenConnect remote service to install drivers and other updates for customers.
Roger H.

Regarding the file size variation.

Then, is there not a file size difference when uploading from a Windows NTFS file system to a Linux Server file system ?

Not normally if you make a direct copy, but file sizes can change when you transfer via FTP in ASCII mode.

You may need to diagnose what's actually happening to the files at your end to work out why the sizes are changing, since we can only really make guesses from here.

See if the file sizes change back, and if the files are byte-for-byte identical, if you re-download them and compare them to the originals.

Check what happens with another FTP client.

Double-check that you're using binary mode in Opus, and that the change you have made is actually affecting your synchronize operation. (After making the change, fully exit Opus (via File / Exit Directory Opus) and restart it, to ensure no cached connections are being used. And make sure you connect to the FTP site using the FTP Address Book in Opus, not a saved layout which may store old settings. Verify that binary mode is being used for the transfers by checking the FTP log in Opus.)

Make sure nothing on the Windows side is modifying the files (e.g. to change metadata, or latent changes made just by opening the files in some software, which MS Office can do sometimes).

I have been very busy with other things like taking care of David Hass now 98.5 years old and proving a hand full with extra care needed.

However the situation / issue with the synchronization remains and is not fixed !

Further to this issue I am also having difficulty in beta 12 installed on Windows 7 Ultimate, the errors are different from the issue on my XP Pro SP3 workstation.

On bets 12 it fails to synchronize document type files and others seem to be OK.

So what is the fix for this on the XP Pro SP3 and Win7u workstations ?

Roger H.

G'day Leo or Jon,

Now that my private live has settled down reasonably, I can get back to this Topic and here is my update, i.e. the problem is not fixed and I need this solved please ASAP.

I have tried to synchronize from my Sydney NSW Australia location (Australian Eastern Time Zone UTC+10:00) using 1. my XP Pro SP3 Workstation, or 2. my Windows 8.1 Pro Workstation attempting to sync to my folder on my Linux Server (SSD) account in Chicago Illinois USA and it will detect the files for synchronization except that it will want to re-upload the same 4052 files in 810 folders (varies constantly due to updates) each time it was synchronized the first time.

The settings are still the same as you have previously advised with the time zone adjustments for Chicago Illinois USA set at (GMT -06:00) Central Time (US & Canada) and the [/] Adjust for daylight saving changes (box ticked)
Obviously I have tried some variations like using or not using the daylight adjustment however where once upon a time the synchronization in older versions of Directory Opus worked in the current 12.5.1 it does not.

To currently synchronize my files I am using my iDrive account which loads the 4052 files in 810 folders from my iDrive-Sync folder on my XP Pro SP 3 workstation to my iDrive account and from there to my VPS Windows Server 2012R2 in Nûremberg Germany to the designated folders.

I have then tried to Sync using DO v12.5.1 the 4052 files in 810 folders from the German Server to the Chicago Illinois USA server and the first time I did so it looked good, obviously much faster average 1.28Mb/ps all looking good except the next day I wanted to update the USA server with about 120+ files in 4 folders that had changed and it went back to square 1 ( one) wanting to re-upload the complete 4052 files in 810 folders.
The German Server time was set at (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna / and the USA set at (GMT -06:00) Central Time (US & Canada)
Further attempts with the server time set to (Australian Eastern Time Zone UTC+10:00) still failed
I have attempted minor variations in settings however the sync just refuses to work correctly.

You are most welcome to use either TeamViewer or my own ScreenConnect to log-onto my Workstations in Australia or my Server in Germany to check the DO settings for the sync tasks.

I would greatly appreciate your help in finally solving this file and folder synchronization from any location to any location ASAP please.

Roger H.