Synchronize Bewilderment

Good evening,
I've been using Dopus for quite some time now, originally on my A-500. For some reason, (either I've forgotten or messed up a preference,) I'm having an issue with sync'ing drives. As an educator, I need multiple backups of critical information, so I have several drives mirrored (not raid, just manual.) When I go down the directory tree, folders are sync'ed with no issues (eg. M:/music/my music is sync'ed with Q:/music/my music), but when I do the entire drive (eg. M:/ = Q:/ or a higher level like M:/music = Q:/music) I get a 'compare' result that states I have to replace the entire content. I've tried checking all 'copy attributes' on preferences, some, and the default setting, and I've stumped, bewildered. I've copied the content over several times to ensure the time stamps/size are change. Any and all help would be greatly appreciated!

P.S. I recently upgraded to Dopus 11, thinking it might have been my Dopus 10 giving me trouble...same issue with ver. 11.

Please show some examples of things being synched which don't need to be, and the configuration of the sync panel.

Thanks Leo.
Here's the information. I appreciate your assistance.
I'm teaching in the morning, so I'll be off for the night.

The N: drive seems to have an extra folder level, called My Videos that isn't apparent on M:. So for example, Opus will be looking on M: for a file called M:\Video\My Videos... and since they aren't there, it will want to copy the whole folder across. If you don't want to replicate the folder structure exactly then you need to set the starting position of the synchronise to the lowest common denominator - in this case, on the left you would set the sync to start from N:\Video\My Videos.

Hi Jon,
Thanks for the input. M:/ drive was a new, empty drive with no files, and the existing structure was a result of the 1st synchronization between N:/ and M:/. What appears to be "/My Videos" is the Library name given by Win7, but as you can see by the image below, it has the exact same directory structure.
Could the issue be that on one of the drives (M:/), the directory is set as the default My Video library, whereas on the other one, the directory is not set as a library?


What do you see if you go to N:\Video and M:\Video in Explorer? (Like your last screenshot, but one level up from the two "JPC - Video" subfolders.)

Hi Leo,
The image below shows the Library name as it did in the DOpus view. When navigating to lower levels in IE, it does show the same Dir name structure in both drives. N:/ is no longer a default location for my Win7 Library, and yet the Library name is still showing. The only thing I can think might cause the issue is that I took it off the Library location list after I did the original sync.
When I return from work, I'll format the drive again and try resync'ing again now that it doesn't have the Win7 Library association.

I think what's happening is the "N:\Video\JPC - Video" folder has a "localised" folder name, which means the name shown in some places is not the actual name of the folder. This is controlled via the hidden desktop.ini file inside the folder.

I think that is also confusing the sync tool, which wasn't designed to sync such things (as they're only used on system folders). Maybe we can fix that, though.

Turning off Preferences / Folders / Folder Display / Display localized folder names should function as a workaround, I think.

Good evening Leo,
Your suggestion worked well when I sync'ed the Music folders (where before it had asked to replace all files.) That's great !
I also tried something else prior to making that preference change; I had researched the desktop.ini file from work, and found that I could delete it so as to have the folder return to it's default state. That, and ensuring the local name for the folders matched, made the Video folders sinc perfectly as well.
I like the new Dopus 11 feel and look.
In parting, as you take a break from your great support efforts, here's a set of old Amiga Animations rendered in the late 80's / early 90's-

Thanks and regards,