System tray icon not showing


The Directory Opus icon doesn't show up in the system tray anymore. This is not really a big issue, the only thing I cannot do anymore now is close down DO completely. But I am used to opening listers by double-clicking the system tray icon, and that I can't do anymore now.

Dopus.exe does show up in the Processes list of Task Manager, and when I kill the process and then startup DO again, then I do get the system tray icon. It seems like something is going wrong at bootup.

I believe this is not really a Directory Opus problem, but it shows up using DO so I was hoping someone here has some experience in fixing it. I have the same problem with eMule (not showing its icon in the system tray), but UltraVNC and QuickTime show up with no problems.

Is WindowsXP hiding the tray icon? (Little arrow to the left of the icons?)

Is Preferences / Miscellaneous / Windows Integration: Add icon tot he Taskbar Status Area turned on?

You can also lose the icons of some programs when Explorer crashes and restarts but Opus should (and always does in my experience) add its icon back in response to Explorer restarting. Some programs don't do this, though, so you have to restart them or reboot.

If you need to shutdown Opus via another method you can add the Exit Program button to any toolbar or hotkey.

No, this is not the problem. I checked the "hidden" icons, DO is not there.

Yeaps, that option is checked. Like I said in my original message, after I kill the DO process and restart DO, then I do get the icon.

This icon problem is there every time I boot, rebooting hasn't helped. I don't notice anything special at bootup like Explorer crashing. The only solution is exiting DO and starting it again.

Thanks, I didn't realize that was also possible. But the possibility to double-click the tray icon is more important to me.

Any ideas why the icon doesn't show up while the program is loaded?

None I can think of. Wonder why it affects Opus and eMule but not other programs.

If you turn the Opus tray icon option off, press Apply, then turn it on and press Apply again does the icon appear?

Good suggestion! Turning the icon off and on indeed does display the icon in the system tray. But after rebooting it's disappeared again...

Doing some deeper research, I discovering I am missing more icons than I thought:

  • Directory Opus
  • eMule
  • SpeedFan (yeah, that one used to be visible until yesterday...)
  • Samurize
  • McAfee
  • Volume Control (yes, the default Windows one... dis- & enabling it from Control Panel temporarily shows it, but gone again after reboot)

The only one visible at the moment is UltraVNC...

Going to Customize Notifications also only shows VNC as a current item, all others are under "Past Items".

What happens if you turn off the tray icon hiding altogether (Taskbar Properties -> Hide inactive icons)? From what I've seen this feature has never really worked very well.

Okay, I found the solution, and it contains a description nobody likes to hear:

Turns out that disabling UPnP icons in the Network Neighborhood solved the problem. Don't ask why, but apparantly it does.

Finding the information was easy after finding the right search terms. Apparently on previous tries I tried to search using the wrong words...

More info:

[quote="pbb"]Okay, I found the solution, and it contains a description nobody likes to hear:


Are you kidding? I much prefer hearing that to "it's a bug in Opus" :slight_smile:

Hehehe... But a bug in Opus would mean you could fix it... :wink:

Hufff.... Any plans for a Linux version of Directory Opus?

We're waiting for them to start breeding Linux users who will pay for software :wink:

Hehehe good point :slight_smile: