Tabs jump to left

Hi guys. When I click and drag a tab very quickly to the right it jumps to the most left of the tabbar. Was this by design?
It's confusing when it happens.

Also when its the last tab to the right and I flick it to the right (on to he plus sign for opening new tab) then the tab gets on the righthand side of the plus sign, see image. And then if I load tabgroups the tab that should go most left gets right to the plus sign.

Another weird thing is when I drag a second tab to the right of the plus sign and close the tabs to the right of the plus sign by double click or middle click on tabs the file display completely freezes

I'm on opus 12 beta 4, but this used to happen in 11 too. Any ideas? Drawing tabs with visual style doesn't change anything.

Is there anything unusual about your monitor setup, e.g. multiple monitors with a mixture of DPIs, or with negative coordinates on some monitors, or with an extremely large total desktop area?

I cannot reproduce what you've described, but have only tried on a fairly normal setup so far. I can try other configurations to match what you have if anything seems like it may be relevant.

When you "drag very quickly to the right", is the mouse leaving the file display, or the whole window? If so, which windows does it cross and land on? Does it seem to matter?

Thank you for the quick reply leo. My monitor setup is normal single monitor but I do have a larger dpi scale in windows.

By "drag very quickly" I mean just a real small quick drag to the left, mouse is not leaving the display. It's like you click and drag the tab at the same time without holding the click down. I must say that I need to try it quite a vew times to get the tab to jump right to the plus but the jump the the left happens quite easy.

I'll try if this happens after a fresh opus install without resoring my configuration.

Are you dragging left or right? (1st post says right but new one says left. Understandable confusion if the tab ends up moving in the opposite direction. Or does the direction not matter?)

Sorry for the confusion in second post. It should be to the right. I drag to the right, just a fraction really, and quick.

So far I tried a fresh opus install, I deinstalled drivers of gaming mouse and tried a different one. Changed dpi factor of the screen to 100%. No luck though.

I've managed to reproduce it now on a different machine/mouse. Haven't investigated the cause yet but can confirm the problem.

Thanks Leo!! Thats good to know.

This will be fixed in 12.0.11 beta.

Thanks a million times guys!