GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Taskbar Icon missing


I found some old forum posts but none solved my problem. The icon on the right is Dopus. It has no icon. I have also logged on as admin and deleted all the iconcache.db files but no change. It’s not a huge issue, but I would like to see the Dopus icon.


First, try unpinning the icon, then re-pinning it (if you want it pinned), via the icon’s right-click menu. That may fix things if Windows has the wrong icon pinned.

If that doesn’t work, please try using Clear Icon Cache. (Deleting iconcache.db by hand is not enough. It has to be done when the shell is not running, and there are some other files that may also need to be deleted.)


Unpinning and pinning gives me a blueish icon. If I close the lister and open a new one, I get the same problem. Used your tool, tried running it normally, tried running as Admin, running from Dopus as UAC elevated tool. The tool says it can’t find any iconcache files. If you have a list of files, I could try to do it manually.


What is the blueish icon? Can you post a screenshot?


Of course. So this is how my taskbar looks like if I pin and unpin:

This is the same icon the Lister shows.

If I close the Lister and open it again, I get the blank icon. Very strange.
This Opus installation is fresh. 12.6 Build 6369 on Windows 10 Pro x64


The blue icon should only show if Opus isn’t pinned, unless taskbar grouping is turned off (looks like it is on, though).

A blue icon for an individual window is normal if that window is a dual display. (You can change the icon colors for different states under Preferences / Display / Colors and Fonts: File display icon.)

But when the icon is pinned, it should use the icon for the whole program rather than the icon for any individual window. The shell seems to be confused about what that icon is on your system.

Since you’ve already tried clearing the icon cache and unpin/repin, the most likely thing is that the registry settings which define the App ID are incorrect. Reinstalling Opus over the top of itself should repair the problem if that is the case. Be sure to reboot at the end when prompted.

If that still does not fix it, it might be worth trying an uninstall, reboot, then install. But before using the uninstaller, be sure to backup your configuration (Settings > Backup & Restore) as uninstalling will wipe the config. You’ll have the factory settings afterwards, but can then restore the backup via the same menu.


Hi Leo,
yes I have a dual display. I have now tried:

  • Installing over my installation - no change.
  • Uninstall, then using your cleariconcache tool, re-install.
    I rebooted between each step. All my other icons work fine, only Dopus has the issue.


You’re probably running into a Windows shell bug (there are still a few to do with icons, even in Win10) so how to fix it may require some experimentation.

I found this which has the suggestion of changing the icon size, then changing it back:

Found several other threads on the same problem, but they only had things we’ve already tried in this one.


Already tried that after consulting Google.
However, if I switch in Taskbar Settings “Combine Taskbar Buttons” to “When taskbar is full” it will show the correct icon (Windows will then show a description of the running program).
The correct icon will be displayed even after closing and opening DOpus.
Very strange.


I fixed it!
I saw today that the shortcut to Dopus in the Start Menu also showed the white icon. I right clicked and then on change icon.
Then I got a message that the location could not be found because it pointed to Systemdrive /system32 etc. I then browsed to the correct location and picked an icon.
Now my taskbar icon is fine.