Temporarilly disable AutoPlay?

Well this is the situation I have. For .iso files I have a couple of options if I right click, namely "Mount image" and "Mount image and display in lister".

For the second option, in an ideal world I would like to disable autoplay, mount the image, display it in lister, then restore autoplay to what it was. Its not of major importance, just one of those things that would be "nice", at the moment, each time I select the second option I get it displaying the contents of the .iso in the lister but have to close the autoplay dialog each time.

I know I could just disable autoplay, but I want autoplay enabled in most situations, just not the in the above conditions.

Any way of being able to achieve this?


FWIW, AutoPlay is a feature of Windows rather than Opus, and Opus doesn't have any say in what AutoPlay does at all.

(AutoPlay may tell Opus to open a folder, if Opus is assigned as the default folder handler, but even then Opus isn't involved in the decision to open the folder, only the result of the decision.)

Not sure what the answer is, though. Maybe there's a command-line tool (or registry script) that could toggle AutoPlay but I don't know.


I realise that AutoPlay is a function of windows, but just wasnt sure if there was any "hack" to what I wanted to do. I believe there is a registry key that could be turned on/off, but in all honesty im not too sure how I would do that in DOpus, and worry a little bit about timing, im unsure but I think I may turn it back on too early, ie before the image is actually mounted.

I presume you would want to do something like :

OldAutoPlayState = GetAutoPlayStatus()
WaitInSeconds(5) ## to allow time for image to mount

Of course the above are not actual DOpus commands but just a way for me to "think out loud" of how it may work.

Makes sense. Sounds fiddly though, given the varying amount of time it seems that it takes for AutoPlay to kick in.

Do you ever want AutoPlay enabled for the drive letter(s) you mount ISOs to? You can enable/disable it per drive letter.

Ahhh, thats a good idea one drive setup with autoplay (the drive I usually use) and then set the other drive with autoplay disabled for me to mount images to that I dont want autoplay to appear.

Thanks mate.

Keeping Shift pressed when mounting drive doesn't help?

Dont know, didnt try that, but it's not really a great solution. The method leo works fine, so im sticking with that. :sunglasses:


There are extensive AutoPlay and AutoRun articles in Wikipedia.