The File Log is almost empty

I'm not sure if this is a general bug, or just some issue with my Opus config data. But i found, that the file protocol list in the multi purpose panel is completely empty, not a single entry there. I have never seen this before, it always used to work. Can anyone confirm this? Just for information, i have recently updated my system to the new H2 version of Windows 11, so that could matter. I have also tried several older config files to see if there is a difference, but the list keeps being empty.

I use the custom setting ("user"), with 16,000 items, and the standard settings like copy/move/subfolders/delete/make dir/rename etc., and i'm also sure that it always worked normally, since i use this feature every once in a while.

Edit: i just have made a test, and this is very strange. I have deleted a file, and made a new folder, both actions show up in the list now. But the list should be completely full of entries, since i have copied hundred thousands of files to my new backup disk, also having deleted lots of stuff, made dozends of new folders, and so on.

You mean the File Log in the Utility Panel?

(Or the Undo Log? Similar but very different in terms of what they save.)

What is configured under Preferences / File Operations / Logging?

Yes, i mean the file log. The undo log is ok. Here are my settings.


Here's how it looks. Two lone entries in the list.

We were talking about clearing old history a few days ago. Did you set something up which deletes the log or State Data folder it is in?

No, i have just mentioned that it would be good to exclude some drives. I also had a look into that file, without changing anything, i also didn't try the RECENT CLEAR command, which would have wiped all 16,000 entries. That was two weeks ago.

I have bought the new harddisks on monday, and since then i have copied over around 3 TeraBytes of data. So there ought to be a lot of stuff in the log. Maybe the vast amount of data overloaded the log, purging the old data? Here is what i find in the State Data/MRU directory:


My mistake, the log is stored under /dopusdata/Logs/funclog.dfl (paste that into the location bar and it'll find the proper location on your system).

Does that file exist for you?

Maybe try deleting it and restarting Opus, in case it was corrupted somehow. Alternatively, something might be blocking Opus from writing new data to it, perhaps.

Yes, the file existed. I have backed it up, then deleted it, and the log now shows both of those actions (copy the file, delete it), but is otherwise empty. So new data can be written. I didn't use any "registry cleaner" kind of stuff, but i sometimes find Windows' security features somewhat suspicious. Regarding the funclog file, wouldn't older backups not contain that file, or is it not included when restoring older backups? Actually, it is not any kind of serious issue here, i am just wondering what happened to that long list of actions. One thing comes to my mind regarding the Windows security features, as i had tried to speed up the transfer speeds, i had tried one tip from the web, having turned off the real time protection and the cloud protection for a moment, and turned it back on, because it didn't have any impact on the copy speed (which later was much better with non-JPG data).

I will watch the content of my log file now, having still a lot of files to copy over, and report back to the forum later. Thanks!

Edit, i have just copied over 4,000 files to the new disk, and after finishing they all show up in the log.