The metadata pane doesn't show data for AVI files

When I click an AVI file the metadata pane doesn't show any information for that file.
If I clicked another file before I clicked an AVI file the metadata pane still displays the information of the previous file (except grayed out).

I also have the same version of Dopus running on my laptop and there the metadata pane does show the information for the same AVI files.
I compared the configuration of the movie plugin, but couldn't find any difference.

Also extra information such as duration does show up for AVI files in de lister columns.
And all other video formats I've tried don't have this problem.

Any idea what could cause this.

That sounds like something is locking the AVI file.

If you're in Thumbnails mode, try using File > Exit Directory Opus to close down the program entirely (in case the lock is inside the Opus process), then try again but stay in Details mode.

If things work in Details mode but not in Thumbnails mode, chances are that one of the Windows or third-party components involved in getting the thumbnails is locking the files. I've seen that happen with some bad video demuxer DLLs, for example.

Could also be other things like antivirus, or search indexers, or something else that might open the files or get involved when Opus tries to open them.

I was already in detail mode and I tried turning off the antivirus, but that didn't help.
It could be something else is locking the files, but I have no idea how to find out what.

I did notice the metadata for AVI files does show up in the Explorer detail pane.
But that probably uses other means to get the data.

I used Process Explorer to see if any process keeps the files in use.
It comes up with dopus.exe twice, even though I closed Dopus with Exit Directory Opus and only clicked that file before I did the search in Process Explorer.

When I do the same for an mp4 file, it comes back with 0 results.

It may not be Opus itself. (And probably isn't, since the same thing isn't happening on your other PC, presumably tested with identical files.)

It's more likely to be a demuxer (splitter) or decoder (codec) DLL that's going wrong, or a shell extension, possibly. Those get loaded into the Opus process, so anything they do is attributed to dopus.exe, even though we have no control over them (other than to block them from loading entirely, if we become aware of specific problem components).

(I would not rule out antivirus entirely, either. Even when it's disabled, it usually still hooks everything and can go wrong, although in the case of video files I would say antivirus is the less likely cause, behind the others.)

Using Process Monitor and filtering on the file in question can reveal what's locking it and then failing to unlock it, although you have to pair up all the locks and unlocks to find the one that isn't matched. Process Monitor can show you a stack trace of each operation, which tells you which DLLs were involved.

1 Like


I used Process Monitor and found out the problem was caused by remnants of Logitech Quicktime software I had installed (and later uninstalled) way back in 2012.

1 Like