This action can't be completed (Opus and Explorer)

Hi again. I have started seeing "This action can't be completed because a folder or file is open in another program" consistently over the past week—when I try to rename or delete a file or folder. (Same issue when I attempt to use File Explorer.)

I am certain that no other application is accessing the file. In one case, I received the message when trying to delete an empty folder.

I have turned off 'caching thumbnails' in gpedit.msc, as some videos have suggested. To no avail.

If I reboot the PC and then attempt to delete or rename, there are no issues: I can delete and re-name without any problems. After I open (and close) a file though, unable to rename or delete.

Suggestions greatly appreciated.
Cheers,
Karl

You may have a program that is still running and has set the folder you are trying to delete as its current directory.

That often happens when using the standard File Open / File Save dialogs in a lot of programs (although not all of them work that way). It can also happen when opening a program by double-clicking a file in the folder (for some software).

There may also be hidden files which could be locked by programs that you didn't notice, if any filtering is turned on.

Process Explorer has an option to find which processes have files/folders locked, which may help narrow down the process holding the lock.

(If the process is Opus and/or Explorer, it's possible it isn't the programs themselves locking things but a shell extension that hasn't closed something when it finished, or possibly when it crashed.)

Thank you Leo. How to you direct Process Explorer to find active processes related to files & folders? Still searching 'Help' for that one.

Thank you
Karl

Find > Find Handle or DLL from the menus, then type part of the name or path and push return.

Thank you. Case closed.

'Case closed' apparently was premature. Something odd is going on. In trying to delete a file from Directory Opus, I'm receiving an error indicating that the file is already open in Directory Opus. (Only one DOpus window is open.) See attached screen shot.

Assistance appreciated.
Thank you.

2018-09-06_17-32-25

It's probably not Opus itself.

It's probably the video splitter or codec which handles that type of video, either leaving the file open or crashing while the file was open, while being asked to generate the thumbnail or get other metadata out of the video file.

A lot of video splitters/codecs are very badly written, on top of the formats themselves being complex, and some software producing out-of-spec files which confuse software if it isn't carefully written.

Replacing or updating the involved codecs/splitters can sometimes get you better behaved components, but is a pretty complex process.

If you just want to delete the file, exit Opus via File > Exit Directory Opus, and the file handle should be closed. (It's also possible Explorer or other software will have a lock, for similar reasons. But you may find they don't, if they do things in a slightly different way which doesn't trigger the problem, or if they use a cached thumbnail. If necessary, try rebooting and then delete the file before doing anything else, avoiding anything that will get its thumbnail. Using a Command Prompt may be the easiest way to avoid that, if it still doesn't let you delete it via a UI.)

Thanks again for the detailed response. Rather than chase this down, I found an application called IObit unlocker that enables a right-click on the locked file. It then unlocks the file, which can be subsequently renamed or deleted. It's free, and it has solved my problem.

Karl

Hi Karl, the application you suggested is awesome, thanks !

Unlocking files with tools like that is not safe. They can be useful as a very last resort, but you should not use them routinely. Rebooting is usually enough, and safer.

You can lose data (including random other files) if you are unlucky with an unlocker tool.

This is by one of the Windows developers:

https://docs.microsoft.com/en-us/previous-versions/technet-magazine/dd547078(v=msdn.10)?redirectedfrom=MSDN

Since Microsoft constantly break their URLs, I'll quote the whole thing here so the text isn't lost in a few months the next time they break them all:

1 Like

Good to know Leo, many thanks ! I'll go for the reboot next time to be safer :slight_smile:

It's really embarrassing as this bug comes and comes again. I don't imagine rebooting everytime :confused:

On one hand I understand the formal answer is to reboot. On the other hand, I have never had an issue with IObit Unlocker.

Dear karlbu,
Many thanks for your feedback after 1,5 year of practice with it. Good to know what we risk, but also your experience. I appreciate ! :slight_smile:

It is unlikely to go wrong, but the consequences if it does go wrong can be catastrophic and confusing. Not worth avoiding a simple reboot, just to delete a file, unless something unusual is happening where the file gets locked again after the reboot.

(In most cases you don't even need to reboot, of course.)

I concur. I would not use IObit Unlocker to unlock the only copy of my PhD thesis that I have been working on for five years.

(Not that I am, but I wouldn't if I was.)

The point of the quoted article is that unlocking one file can corrupt a completely random different file (which might be your thesis).