Thumbnails for .mov and .mp4 crashing after Windows updates

Strange, I came in here to complain about this. I'm also having a crash issue with the movie viewer plugin reading .mov files (specifically, videos taken with an iPhone camera). The crash I'm getting looks just like reck's screenshot. It doesn't seem to have an issue with other types of files. I just had the crash start happening yesterday; previously, it was never a problem. Disabling the "Movie" plugin solves the problem, but then I do not get video metadata in DOpus.

Is there any chance that Tuesday's Windows 10 patch included a breaking codec change? (Since Microsoft is bundling a lot of codecs/splitters with Windows nowadays.) I can't think of anything else that I have changed recently, and the timing between the two of us having the same problem is suspicious.

Aaron, that's a good point about the recent Microsoft patch Tuesday as that's just gone on my machine as well.

I can't be certain when it stopped working for me but it must be recent as I use Opus to manage all my photos and videos from my iPhone and it wasn't that long ago that I copied some media from it.

I've also had to leave the movie plugin disabled until a fix can be found. I've not checked the second link that Leo posted yet so I'm not sure if there's something there that could help?

i wonder if this change also affects movie files that don't originate from iPhones.

Found a slightly better fix, I left the "Movie" plugin enabled and just unchecked the "Generate thumbnails" option in its configuration.

Strangely, thumbnails still show up for my .mov files (generated by the system maybe?), but I get no crashing, so no complaints.

I tried removing ".mov" from the list of supported formats in the "Movie" plugin configuration and leaving "Generate thumbnails" enabled, but it still crashed in that case.

I am also having the same crashing and restarting problem.
However, I have it in folders that DO NOT have .mov files.
The directory I have the problem in has .gif, .wmv, .jpg and .bmp files.

I don't have any iPhone files.

It also started recently. I upgraded to 12 yesterday hoping the problem was fixed.

It was not fixed.

Any recommendations? Did Windows do this with some update? I'm on W10 x64,

Edit: I disabled the movie plugin and the problem stopped. All of the files have icons displayed in the largest size, no issues once I did this.

I'm also on Windows 10 x64 and updated to the latest opus release in the hope it would be fixed.

Something's obviously changed that's made the movie plugin unstable. Other than installing a game i've made no changes to my system other than installing the normal Windows update. It's only circumstantial at the moment but the latest series of Windows update seem to be the likely candidate.

We'll just have to wait for a response from the Opus devs as to the cause and hopefully a fix. In the meantime the only thing you can do really is what Aaron suggested in the post above yours.

It sounds like this is caused by a recent Windows update, but if those seeing it want to send us some crash dumps to look at we will see if there is anything we can do on our side to avoid triggering the problem.

In the meantime, turning off generate thumbnails in the Movie plugin seems the best workaround. You'll still get thumbnails via Windows, just without the sprocket borders.

Hi @Leo,

I've just sent you guys a crashdump. Hope it helps.

1 Like

Thank you for the crash dump.

It confirms the crash is within some Windows code. Unfortunately, it looks largely outside of our control as it's on a thread which Windows is starting, calling code that is part of Windows, with none of our code involved on that thread. My guess is Microsoft have introduced a bug where this code will crash if it is triggered by more than one thread at a time, or if something else isn't done with the same component before the thumbnail code is triggered.

At least for now, we plan to disable the Movie plugin's thumbnails option by default, so the thumbnails are generated via a slightly different route (which apparently does not trigger the Windows bug). These days there isn't a lot of benefit to using the plugin's method anyway, so this isn't a bad solution.

Following up on that, the bug Microsoft have introduced into the AreDvdCodecsEnabled API (which we do not call directly, but the MP4 components in Windows appear to call before doing anything) has been causing crashes in multiple programs, not just Opus:

  • Plex has problems with an update in January, and found some kind of workaround (I haven't found the details yet, if they are published).
  • Microsoft thread which mentions PowerDVD, DVB Viewer, Power Media Server and even Windows Media Player. Opening a folder containing MPEG2 files crashes dllhost/COM Surrogate, with it still happening within the last couple of days and more recent updates.
  • Another Plex thread which mentions several other programs also having problems, and has some more detail. KB3216755 seems to be the cause, and is included in a recent roll-up update.

So this is definitely a Windows OS bug, and you'll probably see a lot of other video software crashing until it is fixed.

Hopefully the workaround we have planned will stop Opus crashing, but it may just make it less common, based on the above.

The good news is that since the Windows bug affects so many things, Microsoft are more likely to fix it.

Good to hear ! i have this crash often in thumbnails mode, since a long time (not just since the last update). on very specific file (even .mp4 with H264 codec), it's very rare but when it's happen it's a pain in the a** :D. i'll try immediatly the workaround, hoping i'll still be able to use the thumbnails feature until microsoft fix this ! thanls :slight_smile:

If you've been having it for a while, the Windows updates might add to it but the underlying problem will be a bad video codec or splitter on your machine.

The HOW TO: Enable/fix playback of various media formats in Opus guide linked above (4th post) has suggestions for that.

You may find the same workaround (disabling the Movie plugin's Generate Thumbnails option) also works, as it'll cause movie thumbs to be generated via a different route which may not trigger the codec/splitter bug, but it may still happen, depending on the nature of it.

I just tested it and the 2 files that i'm sure was crashing opus by disabling the tumbs from the plugin are not crashing anymore ! :slight_smile: i'll Watch the other topic "how to. enable...." in case it's happen again ! Thanks :slight_smile: !

I have the problem with .mkv files as well.
Unfortunately disabling the thumbnail option does not solve it. Only completely disabling the Movie plugin prevents DOpus from crashing.

Are we still talking about thumbnails, or movie playback in the viewer pane?

Sorry, posted too fast.
Yes, my crashes are related to the playback in the viewer pane.

Probably unrelated to the Windows 10 thing.

The HOW TO: Enable/fix playback of various media formats in Opus guide linked above (4th post) has suggestions for that.

Microsoft released another patch today, KB4015438, which looks like it is supposed to fix the issue introduced in the last patch.

1 Like

[Merged to existing thread.]

When i open the folder in details or combined mode, no crash occurs. But when i change into the thumbnails view, the lister crashes. The folder contains mostly images, & it's organized in manual sorting mode, which obviously is causing the crash. If i remove the manual sorting befor changing, no crash happens. I have appended the crash dump. (36.4 KB)

It's the Windows update bug that lots of people have reported recently and is mentioned in the banner at the top of the site currently.

If you update Windows the problem should go away.

1 Like

thanks, Leo, that fixed it. I had a brief look at the banner, but didn't realize a small video clip was somewhere in that folder. :slight_smile: