GP SoftwareTwitter
Opus FAQsManualCommandsObjects

TortoiseGit overlay doens't update while Explorer shows correctly


#1

Initially Directory Opus displays unchanged icon for all of my versioned files.

Once I made changes to a file, Directory Opus still shows the unchanged icon, while Explorer correctly shows modified icon.

The following is DebugView output.

How do I let Directory Opus show modified icons?


#2

If you refresh (F5) do the correct overlay icons appear, or are they still out of date?

Does it make a difference if you try with a path containing only ASCII characters? (Unicode characters should not be a problem, but it's worth testing in case something is going wrong somewhere.)

If you open Notepad, and point its File > Open dialog at the same folder, then modify some files in another program, do the icons change OK there?


#3

I press F5, the icons are still out of date.

I created a test repository in D:. Explorer successfully detects the Modified state, while Directory Opus shows unmodified icons.

Open file dialog successfully shows Modified icon.


#4

Do the correct icons show if you fully exiting Opus (via File / Exit Directory Opus) and then re-launch it?

Are there any settings within TortoiseGit about where / which programs the icons or shell extension appear in or how they are cached or updated? (e.g. TortoiseSVN has an option to show them nowhere, everywhere or just in Explorer.)


#5

I rebooted my computer, it doesn't work.

TortoiseGit does have option to only show the icon in explorer, but I didn't check it.


#6

If they're still wrong even after a reboot then I'm not sure what is happening. Opus is not directly involved in looking up which icon or overlay to use; it asks Windows, which in turn allows shell extensions like TortoiseGit to affect the outcome.

Perhaps an icon caching issue? (Clear Icon Cache might be worth a quick try.)

Turning off both Preferences / Folders / Folder Display / Disable Tortoise icon overlays in the file display and Show TortoiseSVN status icons in the Status column, just above it, may also be worth a try, in case the hooks we use for TortoiseSVN are affecting TortoiseGit in some way. (AFAIK they shouldn't, but I might be wrong.)

A third thing that is also worth trying, as it fixed a similar issue for someone else:


#7

Hi Leo, I tweaked TortiseGit settings again, and now Directory Opus shows icons correctly. Thanks for your help!!