"Transition animations not available" on single monitor

In Settings > Display > Transition Animations

...I'm seeing the message "transition animations not available because there are multiple monitors with different DPI settings..."

Except that I only have one monitor.

My monitor is a Samsung 4K monitor running at 3840 x 2160 native and set to 175% scale.

Any idea why I am seeing this message? I've checked Windows 10 display settings, and there's definitely only one monitor configured. I'm running DOpus 12.20.3 Beta but I also had this with 12.20.

Many thanks!

Have you rebooted since changing DPI? (Or, if it's a laptop, plugging in an external monitor, which can change DPI implicitly.)

It's a desktop PC, and yes, I've rebooted. My monitor and DPI settings haven't changed for nearly a year. I've never had more than one monitor.

Does the system Display settings control panel show that you have multiple displays? Maybe your video card has started misreporting to the OS or something.

Windows display settings and NVIDIA control panel both show that I only have one display configured.

What checks does DOpus do to enable transition animations, is it literally just checking the number of monitors, or is it more complicated than that? What if the checks are omitted, does that cause problems?

It's more than just multiple monitors. (Multiple monitors and high DPI are both fine. Every monitor has to be at the same DPI, and the DPI must not have changed since the system was booted.)

Something that can cause confusion is if any of the Compatibility settings have been turned on for dopus.exe. None of these should ever be turned on:

Thanks for the reply.

My settings in the dialogue boxes are exactly the same as yours above, and have never been any different.

Any other suggestions, please?

If you link your account we can make a diagnostic for you that you can run to see where the check is failing.

Just bought myself a full Pro license and have now linked my account.

Ready for the diagnostic! :slight_smile:


Here's a test version:


With that installed, click on the main file display and push the > key to open a command field:

2020-05-14 18-08-22 Clipboard Image

Then type Help TestDPI and push return:

2020-05-14 18-08-46 Clipboard Image

You should see something like this:

Or this:

Click the Copy to Clipboard button and paste the result into a reply and we should then be able to see what's happening.

As an aside, while testing this I noticed that Remote Desktop may trigger this (depending on the DPI of the two systems), but transition animations are disabled over RDP anyway.

Thanks for the file. I installed it and then failed at the first hurdle, as I couldn't find the button to open a command! It just doesn't appear, I can't find it anywhere.


Transitions animations are now working! I went back from your DPI test version to the 12.20.3 beta, and they continued to work. By complete coincidence, when my PC was last switched on it installed the following two Windows updates when it shutdown:


When I switched my PC back on later today to install the test version you attached, it finished installing the updates. Absolutely nothing else has changed on my system. So I assume Microsoft have fixed something?

If it still helps, I'll still install the test version and copy the results into a reply. It may still be of interest why it broke in the first place?

There's no button. Just type a > character using the keyboard and the command field will appear.

No need to. If it's working OK now then it would probably just tell us that everything is normal.

Since yesterday when transition animations first worked following the Microsoft updates, they now seem to work intermittently, about half of the time. There's no clear indicator what's causing it. When I switch my PC on, when I first logon and the first thing I click is the DOpus icon, sometimes it works, sometimes it doesn't.

I ran the command, and the output was:

Process DPI = 168
System DPI = 168
Desktop DPI = 288

Mixed DPI (Process DPI != Desktop DPI)

Please give this version a try:


Yes, that worked immediately after installing, i.e. without rebooting or shutting down.

Process DPI = 168
System DPI = 168
Desktop DPI = 168

Monitor (0,0)-(3840,2160):
(1280,720)-(2560,1440) -> (1280,720)-(2560,1440)
(1280x720) -> (1280x720)
Size preserved

Consistent DPI

Now I'll reboot and report back....

Still worked after shutting down.
Still worked after rebooting.
Awesome, many thanks! :slightly_smiling_face:

1 Like