Trouble dropping File Filter Field button onto a toolbar

I'd like to display a file filter field. I click Settings -> Customize. Then I find the File Filter Field button in the Customize dialog. Then I drag the File Filter Field button onto a toolbar. As I do the dragging, I see a plus sign (indicating that this toolbar is a possible place for dropping the button). But when I release the mouse, the plus sign disappears and the File Filter Field button doesn't appear in the toolbar. When I close the Customize dialog, I see no change in the toolbar (no File Filter Field button).
What to try next?

Can you add ~any~ buttons from the Customize->Commands tab to a toolbar?

Does this only affect the File Filter Field? Can you drag other buttons from Customize ok, or do they all fail in this way?

Also see [Drag & Drop does not work for files or when customizing toolbars) as that may apply to your situation.

I can't add any buttons (or at least, none of the three randomly chosen buttons that I just tried to add).

Did you try the .reg file in the FAQ that Jon linked to? In the past people who have had this problem turned out to have damaged/missing registry entries for something that should always be there as part of Windows (the IStream COM interface). The .reg file should repair the settings if that is the case.

The .reg file worked. Thank you.

Had you ever installed the Nero 7 stuff mentioned in the FAQ? Or is something else breaking this registry key as well? Run any Registry "Cleaners" lately? (Those things do more harm than good...)

Seems very odd that anything is removing IStream from the registry. It's a standard part of Windows that shouldn't be added or removed by any installer/uninstaller.

Registry cleaners - no. Nero 7 stuff - yes.

Seems Nero still haven't fixed their stupid installer/uninstaller, then? :frowning: Or was it an old version?

Could someone who is a Nero customer please mention to them that one of their installers is removing IStream's COM registration from the registry? A link to the CDFreaks thread that's linked in the above FAQ should provide the required info.


I would have thought for sure those guys over on the CDfreaks forum would have had enough to press their case with Ahead software to get this addressed. But it seems different groups think the istream removal is attributed to different packages in the bloated Nero 7 install...

The guys over at AOL have a fix for it as well because it breaks AIM:

And folks in the CDFreaks forum claim it even broke McAfee virusscan...

Anyhow... I wonder if bburd may have only installed an 'older' Nero 7 package. I had read somewhere that Ahead fixed this is later installers... which doesn't mean they didn't break it "again".

Hi everyone,

I've got this exact same problem. I did a search on the forums before posting a new topic and hence I found my way here. I've downloaded the istream registry file that Jon was kind enough to post, but I need some advice with regard to applying it.

My experience of these files is that you double-click on them and then normally the registry entries are created for you. However, if I double-click on this one Windows complains that it's not a valid Win32 application?

Oh, I should add that I'm using the non-licenced 30-day evaluation version incase that's relevant. I have paid for a full copy of Dopus9 but I'm waiting for a reply from GPSoftware.


The zip file should have a .reg file in it that should automatically import itself when you double-click it. If this doesn't work then it sounds like something has screwed up your .reg file association. If you start regedit you should be able to import it manually using the menu commands.


Thankyou very much. I have good news on both fronts. You were right about the file association, I'm not sure how that's happened, but I took your advice and imported it manually - worked fine.
Secondly, and most importantly, it's fixed my problem!

So add me to your list of effected users!


You should apply for a free evaluation licence to increase the limit to 60 days and, more importantly, remove the annoying nag windows that keep popping up. It should be an automatic process; just needs an email address.

[How to get an extended 60-day evaluation)

I did apply for the free evaluation but never received a reply. But, last night I decided I was happy enough with the program to purchase it so I did that instead.

Just waiting for a reply from GPSoftware now. I think their mail has been going to my junk email folder so I've added them as safe.


The ordering (and evaluation) systems are automatic and realtime, so if you haven't received your registration details it has most likely been trapped by your spam filters along the way.

I have checked my spam folder but there have been no recent emails from GPSoftware. I ordered the full version last night, and I paid via paypal.

If you're saying the ordering system is realtime, perhaps I should contact support and enquire about it?


Disregard that, I have received the registration code.


And are you also a Nero 7 user like the others affected by this istream hijacking perpetrated by Ahead?

(welcome to Opus by the way)

I'm not a Nero 7 user now but I did install a trial version at one time. It was very buggy and so I didn't bother using it anymore.