Type-ahead find

Hi, I've been trying out Directory Opus for a few days now and it has been an awesome file manager. However, there's one thing that I currently find very horrifying in my usage of DOpus so far, that is, there's no type-ahead find which I find a very basic and critical function of every file manager. I managed to get it working a few times randomly. It seems that if I have a file copied (or cut) to the clipboard, type-ahead find will work but it won't in other cases. I have thousands of directories in several drives and without type-ahead find, I will have to scroll to get to the folder that I want all the time, which is unacceptable. So can you guys please tell me how to enable type-ahead find (if it's available as a feature) :slight_smile: Thanks.

There seems to be a problem resetting the key buffer. Use to do so, and it should work.

Thanks. It does work although a minor hassle to press all the time. =)

However, when in Commander style, it only works on one side of the pane, and not the other. How do I get it to work at whichever pane that is active at that time? Thanks.

Go to Preferences / Miscellaneous / Misellaneous and turn on Path completion in path fields automatically, as I type and turn off the option below it, Complete paths for local drives only.

(Assuming that's what you mean by "type-ahead find". Shout if I got the wrong end of the stick. :slight_smile:)

Wrong end of stick old chap :slight_smile:

User61: I suspect you may be in Power mode - check the current mode set in the View menu. If so, turn on the "Activate Keyboard Mode when a partial filename is typed" option in Prefs / Listers / Power/Details Mode and see if that fixes it.

You don't need to press escape all the time - the keyboard buffer resets itself automatically 750ms after you press the last key.

I'm in Details mode and the option stated has already been turned on. Type-ahead find seems to work fine on the righthand-side pane though. It refuses to work in the lefthand-side.

For those who are baffled by the term 'type-ahead find'. You can open Windows Explorer and see a simple example of how it works. Navigate to your C: drive. Make sure Windows Explorer is the active window and type 'w'. You will see that the folder "WINDOWS' or 'WINNT' is automatically selected.

Which paths do you have in each side of the lister? Does the problem stay the same if you swap them over?

Hmm, 2 minutes after I posted the above, I cycled through a few other lister style tabs and finally changed back to the "Commander" style, type-ahead find now works on both side of the panes! Feature, bug or user stupidity? =)

I bet you were using a style which turned on Power mode for one side of the lister without realising it. Then again, maybe not since type-ahead still works in Power mode (if you've got the option Jon mentioned on, which you do). It works slightly differently, though: In Details it selects the file but in Power it just moves the keyboard cursor (the dotted rectangle) over the file (requiring you press space to actually select it).

If you want an extra visual indication that makes it easy to notice when you're in Power mode instead of Details mode (since they look very similar), you might want to turn on Full-row selection for one of the modes and turn it off for the other (as you prefer) via Preferences / Listers / Power/Details Mode.

Another option in the same place which may have an effect is Sort-field specific key scrolling. If that is turned on then what you type is matched against the sorted column and not the Name column. So you can't find a file by typing its name if that side of the lister is sorted by date, for example. If you turn the option off then it always matches against the Name column. (Like Full-row selection, the option can be set differently for Power and Details modes.)

So... Yeah, I'm not sure exactly what was going on before but it was probably an unexpected combination of options/modes. If the problem comes back let us know and/or try the things I've mentioned.

I frequently let DOpus run while I go to sleep and this morning when I woke up, (without touching anything before this) type-ahead find didn't work anymore. Freaky. Anyway, I think I found the problem (but I have no idea why it worked the night before and it didn't after I woke up). I suspected that I might have saved some preferences or some settings unknowingly so I cleared all preferences settings to the default but that didn't fix it. Then I went to Folder Options and cleared the settings to default and it fixed it! The problem is as nudel suspectetd. The Sort by option was set to something else other than filename. Thanks to all. You all have been incredibly helpful! Nudel should get some award or something =)

Glad it's worked out. :slight_smile:

I think it's on by default but, in case it isn't, you can make the sorted field have a different background colour so it's always obvious which field is used for sorting (without having to look in Folder Options). This is configured in Preferences / Display / Fields with the top item called Current sort field.

I have reached a difficult situation. I would like my files and folders sorted by Type and still have type-ahead find working on filenames, like what windows explorer does. Can this be done?

Yes, just turn off the Sort-field specific key scrolling setting mentioned above.

Nudel, I'm officially your biggest fan :smiley:

One other small comment on typing in "find". If, after executing the find command, you are too quick in typing in the string to be found, the first character or two of the sting are not recorded. Is it possible for these key strokes to be recognised earlier?

I'm not sure exactly what you mean. Are you talking about when using the Find panel? That's unrelated to the "type-ahead find".

Or do you mean when using "type-ahead find" to find one filename and then the other? If you type two letters, say "A" then "X", quickly then Opus will look for a file starting with "AX". If you've just typed "A" and then want to jump to the first file starting with "X" then you just have to wait about 1 second before typing the "X" so it's recognised as the start of a name rather than a continuation of the previous name.

I realise it is not directly related. Yes, I am talking about when using the Find panel. If you type the string to be found, too quickly after selecting it, the initial key strokes are not recorded.

I can't reproduce this. Are we talking about the separate Find window (File->Find in the default menu) or the Find Panel (Tools->Find Panel in the default menu)?

Within that, do you mean that after you click Find, wait for the Find to finish, and then select the Name Matching field, it takes a while before your keystrokes register? That doesn't happen for me, although I've only tried a small Find operation.

Are you using the latest version? I do know that the Find Panel was a little slow to open on earlier releases.

I cannot reproduce your problem here - if I start typing as soon as I select the Find Panel button all keystrokes are in the textbox once the panel finishes opening.

Slow pc perhaps?

Thanks. That is not happening for me. I guess I must blame it on my PC, but it is certainly not "slow"!