UAC and context menu applications


I just installed 7-Zip on a fresh Win10-machine with Directory Opus 11.19.
The context menu has all the extraction options readily available on archives.
However, since DOpus is not running in elevated mode, I cannot use 7-Zip (or any other application that requires elevated mode).
A message box tells me "the requested operation requires elevation".

Running DOpus in elevated mode solves this problem.
But... [url]Why NOT to run Opus as Administrator under UAC] says you're not supposed to do that.

How do I run elevated applications from a non-elevated DOpus?

(I have check "Run this program as an administrator" for all users on the 7-Zip executable.)

You can use Opus to extract 7z archives and Opus will handle UAC automatically. No need to use an external program to do it.

However, if you want to, use an external program and elevate it, click the Admin button on the default toolbars to switch the lister into Admin Mode. After a UAC prompt, that window will then be elevated, and most operations you perform in it will be elevated as well. That includes launching 7-Zip via its context menu. (Tools where the context menu only sends a message to an already running instance of another program won't be helped by this, since the other program won't get elevated, only the thing which sends it a message.)

You can also add @admin to the start of commands to make them trigger a UAC prompt (if not already in Admin Mode) and run just themselves as admin (without elevating the whole window).

Also note that none of this is possible in Explorer at all, while the context menu items are actually designed for Explorer rather than Opus. So most of these tools are not designed to work with UAC at all, but Opus can allow them to be used with it via various workarounds. A well-designed context menu item should handle UAC by itself, but most things do not, sadly. (I am still waiting for a text editor that works with UAC, after over ten years. It's getting annoying! I can launch one elevated from Opus, but they really should handle it themselves by now, so you don't have to know you're going to be saving files in protected folders in advance and open them specially.)

Thank you very much for a very fast answer!

It was not the answer I was hoping for, though. I had hoped there was some trick I could use. (: I'm only encountering these problems now, because I have stopped disabling UAC altogether on my computer.

Honestly, using DOpus built-in archive manager never occurred to me, as I've always used WinZip/WinRAR/7-Zip. But now I'm only using DOpus, so your solution for that part of the problem is solved. Thanks a lot! (:

The Admin-button works as well.
It's a bit cumbersome if it's a frequently used operation, but I can get used to it.

If it's a frequent operation, you may be able to replace the context menu item with one that runs the same or a similar command and includes @admin to make it elevated. The exact details will vary depending on how the context menu and program it runs work, however.