GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Unable to Download DOpus Latest


#1

Hello there,

I think it has been 3-4 days now that I've been trying to update my DO 12.7 to the latest version but I'm unable to download the file both from inside via Check for Program Updates or even via website.

When I try to download directly through website and click the download link it times out connecting to:

http://cdn.gpsoft.com.au/Opus12/DOpusInstall.exe

I have no problem accessing any other website, or even your website. I'm from Pakistan. Can you please check if there is any restriction to downlaod it from my country?

Regards,

M F Faruqi


#2

Link is OK here, FWIW.

We don't have any restrictions on where people can download from.

What error message do you see when trying in a web browser?

Could your local firewall or antivirus be blocking things?


#3

Just confirming, that link worked for me too, Leo.


#4

I am also unable to download version 12.8. I've tried with the Opus built in "check for update" and with two different browsers from the website. Only error is "timeout".

I lose all packets when I ping cdn.gpsoft.com.au

A trace route shows 8 hops before timing out, so the issue is outside my ISP.

Thanks


#5

Can you post the traceroute?


#6


#7

Hi there,

Thank you very much for responding this issue.

The error that I'm continuously getting is:

The connection has timed out

The server at cdn.gpsoft.com.au is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Here's the tracert as per your request:


#9

Thanks, it would be helpful if you could post it as plain text rather than a screenshot.


#10

Thanks again for responding, Jon.

I'm trying to post it as text but I'm getting the error that "new users can only post 2 links in a post. And the tracert has more than 2 links :frowning:


#11

I got a fix. I've copied it in this text file :slight_smile:

tracert.txt (1.8 KB)


#12

Any good news Jon? This problem still persists for me...

It seems the cdn you're using has some issue, and this is not just me.


#14

I’ve reported it to our CDN provider and am awaiting a reply. Since the trace shows the final destination as reachable, and the packet loss looks to be somewhere in between, I’m not sure what they will say, but we’ll see!


#15

I received the following response. Please try your downloads again as it sounds like it should be fixed.


We managed to find the root cause - The Pakistan requests were served from the India PoP but the India PoP seems to block/unable to resolve certain IPs from Pakistan. We have contacted our provider to resolve this issue ASAP.

Meanwhile, we have paused the India PoP and therefore, requests from Pakistan will be going to another PoP.


#16

Thanks, Jon. I just updated DO through the built in updater successfully.

I hope this issue will get fixed permanently.

Thanks again for the prompt resolution of this issue.

Great service.

Regards,

M F Faruqi.


#17

I still cannot download either from the built-in downloader or the website.

Thanks

EDIT: As of today, 5/15/2018, I was able to use the DOpus built-in updater to update to version 12.8. Thank you for resolving this issue!

Note - the 3 reply limit on new users makes no sense for a tech support forum!