Unable to play any movie files with latest Windows Update

Just received the latest update of Windows 10Pro, and now when I double-click any movie files, DO does not respond. I am able to right click the item, and use OpenWith and set the DefaultPlayer that I want to use (and it works in this instance). But, the next time I double click anything (including the just-played item), DO still does not respond, and the AlwaysUseThisApp checkbox is not checked. Also, right-click Open, does nothing. So I end up having to right-click, OpenWith each time.

In the standard Windows explorer, I am able to double-click and it always correctly plays the movie item using the default Windows file handler (in my case, Movies & TV).

I am on DO 12.21, but I seem to have messed up my DO settings somehow. What are the settings needed to have double-clicks be responded to and "passed-through" to the default Windows file handler?

What kind of extension do the movie files have? MKV, MPG, TS, MP4...?

I haven't tried all, but I'm mostly using MP4 and MOV. I tried setting up my own double-click process, but with the new Windows UWP method of firing applications, I have been unable to find the correct syntax to pass the filename to be acted upon - it's apparently not as simple as just passing the filename as a parameter... I can get the Windows Movies & TV application to launch from DO, but it will not pick up the filename, so that is problematic. The base Windows Explorer is able to launch the correct app with the selected file. But I need to find a way to have DO pass the request through directly to Windows - or find a means to simulate it.

It seems to be too complicated for me. I have VLC media player as default player an it is shown correctly when I go to: Settings > File Types... > System File Types > MP4 > Edit:


Perhaps you can change there the default player. Try to change it to "Windows Media Player" and look if it works. But as I see you can't change it to "Movies & TV" because it is a new Application.

Sorry, I'm afraid I can't answer you more.

A very quick solution / workaround which may solve things:

  • Settings > File Types.
  • Double-click Movies under File Type Groups (or do each individual movie types under System File Types, if you prefer).
  • Select the Events tab and double-click the Left double-click event.
  • Paste FileType ACTION=shellex as the command.

The issue with the Open With menu not working correctly may be the return of this Windows 10 problem:

That post has a solution which worked for me. (Change .png to the extension you're interested in, of course, and change pngfile to what the assoc command reports for the extension.) But it's also possible it is a different issue.

Let us know if neither option solves things and we can diagnose what's going on further.

1 Like

Leo that's brilliant! It worked for me! I did have to add mp4 and mov to my list of filetypes - for some reason they were not in the list. But once they were added, all is working again - and it is using the defaults that I set on the Windows side. THANK YOU!!!

1 Like