Unclosable Output Windows

Whenever I run a file search, Opus opens an Output window for the results. The problem is that there seems no way of closing it. There is no File Exit menu (or any other menu) displayed, and the window is infinitely wide, so that scrolling the box left to get to the usual X is impossible - it just scrolls and scrolls and scrolls and .....!

How do I shut down this window?

Incidentally, because of another problem (still not solved) with the Nero toolbar which doesn't do anything - perhaps because I have two DVD burners on my system - I did a complete uninstall of the past version and re-installed the latest one. Problems persist.

Using Windows XP Pro.

I also have a problem with monsterous output windows. The problem can be fixed temporarily if I close it the first time it opens, reopen it and double click on the title bar to maximize it. Unfortunately the problem will return the next time I try opening the output window.

I preffer to use the embedded find pane instead of using ctrl+F. I like the way it outputs the results to a file collection, and it completely bypasses the huge window problem.

Do you by any chance use Litestep? I do, but I doubt it has anything to do with this problem.

Sounds like the Output Window is just "docked" to the edge of the screen. Does it have a drag-bar down the left side that you can click on to move it away from the edge of screen? Dragging it away from the edge should turn it into a normal window with a close button.

You can also close it by running the command

Set OUTPUT=Toggle

which is in my tray-menu. (I'm not sure if it's there by default or something I added.)

If you want to prevent the Output Window from being docked you can disable the feature via Preferences / Miscellaneous / Miscellaneous: Allow the Output Window to be docked with the edge of the screen (shift overrides).

Finally, you can avoid the Output Window appearing for search results if you select the option to send search results to a Lister. Then they'll appear in a lister as a File Collection instead. (This always happens if you use the Find utility panel that appears at the bottom of listers, but is an option in the old-style separate Find window which I think is the one you're using.)

Regarding the Nero toolbar, did you edit it to specify your CD Writer drive letter? I've used it with two writters installed on my system before and it worked fine. If you've got the right letter but are still having problems I'd recommend making sure that you can run the command lines from a DOS prompt to make sure Nero (and the Nero command-line tool) is working properly on its own.

I've solved the problem of the humongous output windows! Apparently the output window will never start maximized (unless there's some setting that I haven't found), but will otherwise remember its last size. My output window was originally so large that it was impossible to see the bottom of it by dragging the title bar upwards. Fortunately, I was able to wrestle it into a smaller size using a Litestep module. After that, I toggled the maximized veiw on and off to make sure that it learned the new size. When I closed it and restarted it, it was still in the smaller size that I had set. This seems to be working great with both the "Output Window" option in the "Tools" menu, and the classic ctrl+F find dialog. It even sticks after exiting and restarting Opus.

I see what you meant about not being able to close it though. I tried eneabling the docking option, and found that it would cover the entire screen with an unmovable, titlebar-less window. You can always use alt+F4 to close the output window though.

There is a left hand edge to it but no right edge. However I found that I can get a re-sizing double headed arrow over the left edge and pulling that in even just a fraction makes the window resize and the normal X appear at the top right.

I've also noticed that if that window is open but minimised, closing Opus down still leaves the Output window tab in the Task bar. The only way to get rid of it is via the Task Manager and closing the task there.

However, Nudel's suggestion re the settings solves the problem entirely - I think!

I'll have a look at Nero later - dog wants a walk! Thanks.

Opus doesn't exit when you close a lister window. You can run the Close PROGRAM command (which is in the default tray-icon menu, I think) to make it exit completely.

I believe this search output window is a bug and a big inconvenience.

Not only does the search window take over the entire screen, but it can also impact (resize) other windows on the screen, causing you to have to reset your entire screen environment.

Their may be "circumventions" (as listed above) but the native command state needs a fix.


I've never seen it take over the screen. It sounds a lot like your output window is docked, which is the only time I know of when it will move other things around (because it becaomes a toolbar on the side of the screen). Just un-dock it and it won't anymore.

Just to confirm, my Find dialog looks like this:

For me, the problem occurs when you show the results in an output window, not the find window. Find window, a way to circumvent the problem, seems to work ok


Then your output window is probably docked. Undock it, problem solved. :slight_smile: You can also disable docking of the output window completely (described a few posts above).

Not so - had already tried that before I made the post :smiley:


I'll try reporrting to normal support - just wondering if there was a solution here first.


I also noticed that the output window was infinitely large but I now have it opening full screen and whatever I do I cannot resize the window. It is either full screen or minimized on the task bar. No I do not have it docked and I have toggled the setting to ensure it is set the right way.

I do not want it full screen I would like it to be the size I want and that size to be remembered.

A solution is to use a lister window or the find window.

There really is a problem with the way the output window works IMHO. Looking forward to a fix sometime.

I had a play with this and if you delete the saved size of the output window from the registry then you get what you guys have been describing. (Really, really large output window.)

Have you guys been messing around with the registry or is there something that's causing this?

Anyway, to fix the problem you can download and double-click this reg file:


I've added this as a FAQ item in case other people are experiencing the problem. If anyone has any clues as to what might cause it (beyond deleting parts of the registry for fun :slight_smile:) let me know and I'll include it in the FAQ.

I've also filed a report requesting that the Ouptut Window validates the size settings in the registry. Although the situation is unexpected, Opus should cope with it more gracefully and it should be a trivial fix.

Did you try disabling the Preferences->Miscellaneous->Miscellaneous->Allow the Output Window to be docked with the edge of the screen (shift overrides) option per Nudels suggestion?

Edit Note-
Also, something interesting was that JUST at about the time this topic originally came up, I saw this problem after manually messing around with some registry and preferences export files to clean out default lister format settings and general playing around. It causes the output window to be huge and for the title bar to be crolled way off the screen and made me unable to resize it... anyone else playing around with their registry :slight_smile:?

[quote="steje"]Did you try disabling the Preferences->Miscellaneous->Miscellaneous->Allow the Output Window to be docked with the edge of the screen (shift overrides) option per Nudels suggestion?

Edit Note-
Also, something interesting was that JUST at about the time this topic originally came up, I saw this problem after manually messing around with some registry and preferences export files to clean out default lister format settings and general playing around. It causes the output window to be huge and for the title bar to be crolled way off the screen and made me unable to resize it... anyone else playing around with their registry :slight_smile:?[/quote]
I held off adding a "me too" to this thread, but I now think it might be useful. I just started using Directory Opus 8 a couple of months ago. Thus far, the one thing I've had a problem with is the output window, which fills the entire screen and gives me no way to make it smaller (i.e., the same problem that other people have mentioned). In response to Steje's message, I looked at my preferences, and the bit about allowing the output window to be docked was NOT checked.

I also have not been messing with the registry...except every now and then I will run the Registry Cleaner for jv16 PowerTools 2005. I don't recall its identifying a registry setting referring to DOpus, but I wouldn't swear that it didn't. After looking over the errors it has detected, I always tell it to go ahead and fix them all. I've never had a problem with this--though I suppose if this is what messed up a DOpus setting, then I guess I have had a problem and just didn't know it. :slight_smile: Of course, if this is what's responsible, the next question is why does the usually accurate Registry Cleaner think this registry setting is an error?

Anyway, whatever the cause of the problem, you can add me to the list of people who have experienced the HUGE output window and do not have it set to be docked.

Just to be clear... I freely admit to doing stange things in the registry. From time to time, I like to try and break stuff :slight_smile:. I recently decided to compare my latest exported settings file (DPS) to one I had saved after a fresh and clean re-installation of Opus 8.1 from back when it was released and before I had set things up to my liking. While I was at it, I whacked some of the saved window positions for some of the dialogs to see what happens. I believe I had deleted the binary "output" value underneath the [HKEY_CURRENT_USER\Software\GPSoftware\Directory Opus\Window Positions\System] registry key (actually I think I did this inside the prefs.dpf file and then zipped/renamed/reimported it). After doing so, I noticed two things... the output window would open to a gargantuan size and scrolled of the screen, and while maximizing it filled the screen properly, trying to hit the overlapping windows (restore window) button in the right hand corner caused the output window to actually minimize. I clicked around like mad to try and resize the window to something sensible and got pretty pissed off before I actually fixed it (of course at any time I could have just re-imported a 'good' dps export).

Anyhow, I just tried all this again since I could not remember 'exactly' how things went down, and reproduced the same problem. The way you should be able to fix it is to:

  • have the output window in it's infinitely wide state, and make sure that the left most top hand corner of the output windows title bar is visible.
  • click the LMB on the Opus icon in the top left corner and select the size option.
  • position the mouse cursor over the left hand corner of the window as if you were going to resize it and click the LMB... this should cause the window to actually minimize (weird).
  • when it has minimized itself, click the RMB on it's taskbar footprint and select close.
  • after it's closed, goto Tools and select the Output Window again and when it opens it 'should' open NOT in an actual 'maxmized' state, but it should fill the screen... but now you should also be able to resize the window to something sensible and have it behave correctly.

Edit note- I know GPSoft wouldn't approve, but if the steps above still don't fix things, I suppose someone with it working properly could upload a registry export of a good 'output' registry value under the key mentioned above. If you look at the key after it's in it's gargantuan state, you'll probably see a series of FE 7f and FF 7F values in the binary values hex data. DON'T go dorking around with your registry though - I'm not advocating that :slight_smile:.

As has been surmised, this is a bug.

It was caused by a (simple) uninitialised structure - interestingly, this has always been there but it has only started causing problems since the switch to Visual Studio.NET 2005. Presumably VC++ 6.0 was initialising the (uninitialised) structure differently.

The fix is to replace the value in the registry with a valid one - using the .reg file Leo posted earlier is an easy way to do this.

Note that if you resize the window to a more sensible size, and then close the output window, this will be saved to the registry and the problem will disappear. It is only if there is no size saved in the registry that the uninitialised structure causes a problem.

By the way - you can resize windows like this quite easily using the keyboard. Press Alt-Space to display the window menu, then S for size. This puts the window into keyboard sizing mode. The very next cursor key you press determines which edge you are sizing from, so press the cursor Right key to size from the right hand edge. Then press and hold the Left cursor key to actually resize the window back to normality. Repeat for the bottom edge if needed.


Guess I arrived late to the party... just saw Leo's post on the FAQ with the reg download. So I said sort of the same thing, and as usual with ALOT more words than Leo... blah blah blah, babble.

OK - so I have just installed the program and licensed it. What I think is happening is that on a new install the registry keys are not created (for each user - or are they common?) therefore the window is as large as it thinks it wants to be.

However having opened and closed it I think the keys are then written and it then opens as a full screen widow. However trying to resize it just makes it minimize. So there is still something other that the registry entries.

And no - I have not played with the registry.

One other point - would it be to do with installing with admin privs and then running as a user without admin privs - not tested that option but is seems to be a common fault with a number of software packages that will only run properly when you have admin privs.

(Admin prives when browsing the internet etc. or even using your PC on a day to day basis is not a good idea. I know that some versions of the OS it is not easy to change - but I run without them)

rayg, Jon already mentioned it's to do with an uninitialized structure... and the fix is either what's mentioned above in my last long post, or to download the reg file Nudelo posted on the FAQ forum. The values you have in the registry now are still likely incorrect and are part of what makes the window minimize when you try to resize it.