Unknown Error when Renaming+Deleting

I used the Opus admin option to elevate for a few minutes, opened a folder from Program Files (x86) on my Win 7 64bit system, and then renamed a file, using the same name as an existing file. When the rename dialog appeared, I clicked Replace (Delete Existing File). I then receive an error - 'an error occurred deleting readme.txt, an unknown error occurred' (readme.txt was the file I was trying to overwrite). I can then only skip or abort (retry does nothing). Oddly, the file was deleted - but the file I was renaming was not renamed, so the process does fail.

An associated problem is if I created the copy of the file by copying and pasting the original file - after I receive the renaming error, if I then try to paste the file again (to re-create the deleted readme.txt file), I get the same error, except this time the text is 'an error occurred copying readme.txt, an unknown error occurred'.

Do you get the same error if you try to create a folder in the same location? If so, try reinstalling Opus over the top of itself and then reboot.

If not, does the problem only happen with that one readme.txt file or is it more general?

What happens in Windows Explorer, trying the same things in the same folder?

  1. No, folder creation is fine in Opus.

  2. No, more general - it happens with all files. readme.txt was just one I picked at random for the post.

  3. Explorer obviously doesn't have the rename+delete function of Opus, but Explorer renames fine (when I try and rename, it adds a (2) to the end of the filename, which is basically what Opus does in the normal non-delete rename).

Thanks, I've reproduced this now.

It seems OK if admin mode is not used (even if UAC is required; you'll get a UAC prompt if needed), but when admin mode is used I get the same error. We'll look into this more now that we've reproduced it.

I have the same problem as this error you reproduced 4 years ago. It's crippling my workflow. HELP

This has been fixed for the next update.