Unstable betas

Up until dopus 13.0.45 beta everything seemed to be working fine but as of 13.0.46 beta the program has been very unstable. I had to uninstall it and install the latest dopus 12 version. I think I'll wait until the final stable version of dopus 13 comes out before reinstalling dopus 13.

The whole point of the public beta is to find and eliminate bugs. Could you at least share some details?

I realize that, but the program would send me a message about an error probably caused by a virus and then would close. I simply could not use it. I tried reinstalling, but the same thing happened. The program would end up simply closing and could not be used. That's why I was forced to uninstall it and go back to Dopus 12.

That sounds like the download was corrupt in some way. If you re-download the latest beta and install you'll probably find it's fine.

Probably related to this? @evelyn are you using Defender?

I did re-download. I reinstalled. There was something in that version that simply would not work in my computer. I may try again next month with a later version and see if the problem is solved. But for the next couple of weeks I need a fully working file manager and testing the beta will have to wait.

I'm using Malwarebytes and Microsoft Defender. Dopus 12 works well with both. The Dopus 13 versions previous to 13.0.46 also worked well with both.

Is not that v13.0.46 and up is not working well, is that Defender is giving false positives marking the installer as virus (not only affects DOpus but other programs as well) Maybe is your case...

You are probably right. Next month I will try again with the latest beta and will disable the anti virus before installation. Will enable it again after installation and see if that will fix the problem.

You may not even have to, once a few other people have had the issue. Defender usually seems to decide we're a virus for a few days when we change our signing certificate (which has to happen every few years, and happened twice during the public betas due to an issue with the first key). Once a few people run the new version, Defender seems to understand that it is now OK for it to be signed with that key.

At least until the next time we renew our key, in a few years time. Then the problem happens again for a few days, and we deal with the support hassle and reputation damage instead of the people causing the problem: Microsoft. We're really tired of it at this point.

It is complete garbage on Defender's part, as the entire point of signing keys is proof of authorship, and it's routine for them to be renewed. Yet it decides things are virus because the keys are renewed (unless that's a coincidence, but it's happened four times now over the years).

We can't do anything about Defender other than urge people to use a better antivirus (e.g. ESET/NOD32). If Defender was any good, it would detect and remove itself, because it is a huge cause of problems. Please use a better antivirus, for all our sakes.


I don't really know exactly what a signing certificate is, but I kind of get the idea.
But this is an explorer thing, so Directory Opus gets the impact of the worst of the worst.

So, perhaps a blocked Dopus Beta installation could be done by bypassing this ?
It is really easy, one just needs to reboot into the Windows Recovery Environment and disable driver signature enforcement. Could this work with Directory Opus ?
Naturally, this shouldn't happen at all !

I have had to do this to install unsigned 64 bit USB drivers for an old HP calculators file transfer program. I just wanted access to a USB to Serial Port Cable within the old transfer program.
Windows itself had a total convulsion about it and I had to bypass it.

It works OK, but I prefer my rebuilt with Li-Ion batteries portable floppy drive that connects to these old calculators via a serial cable using KERMIT ( Sparcom Drive95 ). The data rate is only 9600 Baud.

It is so slow, it makes me laugh and smile !

That only affects drivers, which Opus doesn't install. The code is also signed, so it wouldn't require that setting changing even if we did install a driver.

It's purely a case of Defender's heuristics being garbage.

Today I installed Dopus 13.0.50 64bit beta and so far everything seems to be working just fine. I'll let you know in a few days if everything has been fixed, but, so far, it looks good.

I reinstalled Dopus 13 version 13.0.50 on 11-29 and as of today (12-2) everything is working just fine. I added the EverythingDopus utility and after some work around Microsoft Defender it is also working just fine. Thank you all for your help.