Upgrading has broken NOT (~) in FAYT

I don’t know if you changed something or it was me, but I can’t get NOT to work in FAYT like it used to. I’m convinced I used to type a tilde and could just keeping typing till what I wanted to disappear did. But now let me give you an example.

I'll use hiding S001 as an example.
I type a Tilde and everything disappears. (I think this this is the old behavior.)
I type “S” and everything reappears, including files with S in them.
I type 0 and everything disappears.
I have no idea what changed.
I almost always enter the FAYT text box by clicking in it rather than typing an asterisk if that makes a difference.

In the filename - is it O or 0?

Sorry, I instantly noticed my mistake and was starting to correct when your quick post beat me to it. As I was posting I wondered if I should make a point that I did double-check and make sure I wasn't confusing zeros and the letter O. I just stuck with this example because it's something I've done over and over with a series of files labeled S001, S002, ....

~(*S001*) is the pattern I’d use for that.

Thank you that works, but I SWEAR I could do it in V12 without the extra four characters. I almost never use the asterisk wildcard. I think it did partial matching better.

Yeah, I just tried with 12 and it made this easier than it is now.

We may have had special handling to re-write the pattern for you if it was prefixed with ~ and had no (...) after it. A lot of that was specific to the filter bar in the past, and is now part of the more general pattern-matching code in Opus, but it looks like we missed this case when moving things around.

We'll see if we can restore the old functionality. It definitely made things easier.

@leo
Is this not the same as my post 24-09-23
Filter Bar (~ Not) is not working - PrivateBeta - Directory Opus Resource Centre (dopus.com)

Probably is, yes. We missed some of the cases in there.

I was just curious as to what you reported, but your link leads to "Page Not Found."

@pschroeter
Link was to Private Beta part of forum
I used a lot of filters with not ~, and |
In filter if I type ~S001 only S001 shows or type S001 only S001 Shows
now I have to type ~(S001) to hide S001

What have you got in settings

image

With what you said you have Partial matching
Does not matter what you tick ~S001 will only show S001
Was a lot better in Opus 12

Leo already acknowledged they changed things in V13 that changed this behavior. I believe I just have to wait for an update.