USB Export to Bitlocker encrypted drive

I want to run DOpus on my work laptop via USB export as I don't have admin rights to install a full copy. The laptop is locked to open a USB drive read-only if it's not encrypted, so if I do an export to a standard USB drive, it runs initially but stops a few minutes later when it can't write to the drive.
If I format the drive and encrypt it on the laptop (using Bitlocker) and try the process again, it also runs the first time, but after a while comes up with a Licence Manager message "The USB device used to export DOpus can not be found".

Other mentions of similar issues here (all very old) talk about the drive not being recognised as an external device. There's a Win 10 option to open the drive as a portable drive, so that, but it doesn't help.

Is there a way to get this to work?

If the only issue is that the USB drive is read-only, there's a "dongle" option during USB export which lets you copy the files from the USB stick to the HDD (e.g. Documents folder) and run the program from there. The USB stick still needs to be plugged in, but doesn't need to be where the program is run from.

The USB is writeable once it's encrypted, but I still get the error running from the drive. Copying to the HDD and running from there seems to be working for now though.

After a reboot, it's now not working again. Both the local folder I copied the app to and the USB are writable, and the USB is present. I am using an SD card plugged directly into a laptop rather than a thumb drive - would that make a difference?

Have you tried a non-encrypted USB stick with the dongle option?

That was the way I first tried it, but have done again to be sure and the message is the same.
I formatted the SD card and copied again and tried copying to a different location on the laptop, but still the same. Does anything else get written to the local device that I should remove?

Further to this...
I put the SD card into a USB card reader, which mounted as a different drive (F, the card only is E) and now it's working. So I assumed it's either:

  1. I originally copied using the card reader, so DOpus wants the dongle as F, or,
  2. It's because I'm inserting the card direct.
    To test, I pulled that card from the reader and put back in directly, intending to change the drive from E to F - but tested as E first - and it worked. Will try again after a reboot at some point, but for now, I won't touch it since it's working.

After reboot, is not working again, so must be that it's a SD card rather than a thumb drive. Should that cause it to not work?

Opus uses certain information about the USB drive to encrypt the certificate that's exported. On a USB thumbdrive this information won't ever change, but on an SD card part of it is subject to the device that reads the card. If this changes the certificate decryption won't work.

Thanks Jon. So it can never work on an SD card, being memory only, with no on-board electronics from which to draw the encryption salt?

If you use the same reader every time (connected to the same USB port, maybe) then I would have thought it would work, but it's probably going to depend on the hardware involved.