USB License not installed?

Yesterday I upgraded DOpus 8 to DOpus 9 and added on the license for a USB key.
I've installed DOpus9 on my Vista Ultimate laptop with no problems, and then exported to my USB key.

When I plugged the USB key into my WindowsXP disk to do some file copying, and tried to run DOpus9, it came up with a box saying that the license was not installed.

When I copied the license information from my email into a text file and put it on the USB key and tried to load the license, it told me I needed to be an administrator in order to install the license.

Am I missing something, or have I paid for a USB license that I can't use? Or have I missed the point altogether as I presumed it meant that it could be run from the USB key.

Please submit an official support request through the GPSoftware web site. There are some issues with specific USB keys and devices that we are currently looking into. We'd like more details of the specific device and we should be able to provide a solution for you.