Version 12.28 killed my FTP

Since I downloaded the 12.28 release at the start of June, my standard saved local>domain FTP shortcut and connection has got worse and worse. From today, it would barely function at all, frequently failing to connect, and when a connection did succeed, failing to transfer any files in either direction with an 82 error.

I just downloaded and installed v12.27 from this forum, and the 'Universal Installer' provided at that post will not install anything but V12.28.

I even completely uninstalled DOpus and rebooted, reinstalled from the apparent V12.27 installer, and - no good. It's still V12.28 and it still doesn't do FTP properly any more.

Therefore my SFTP (yes, I bought a license for FTP) is no longer working in Directory Opus and I don't seem to be able to revert to a version that did work.

I am temporarily returning to WinSCP, because I have work that I need to get done, but I would be glad of some advice on how I can either fix V12.28 so that FTP works again, or else GENUINELY downgrade to V12.27 (or any earlier version that did work for FTP).

Nothing else in my setup has changed but this (apparently irreversible) upgrade to 12.28, from which point the problems began.

I just had my domain guy on AnyDesk with me, and he connects fine to my site on exactly the same credentials with WinSCP. With WinSCP, it all works fine.

If you check the links on the release notes posts, they all point to the same URL, which is always the latest installer.

We can provide installers for older versions if needed for testing, but we'd also rather resolve issues so you don't end up stranded on an old version forever.

What does the FTP log show when you try to connect to the site?

The FTP log in the Output Window

The FTP log can often be used to diagnose what's going wrong.

To open the FTP log window, select the FTP / Display FTP Logs menu item, then select either [All Activity] or the specific site you care about from the drop-down list of logs.

To make the log show even more information, enable the Debug option in the FTP address book (on the Display tab when editing an FTP address book item or the Default Settings item).

In terms of FTP / SFTP changes recently:

  • 12.27 (Mar 21) had a large update to the SFTP code.
  • That had a bug which made it through the betas but was found and fixed on Mar 23, in a replacement 12.27 installer.
  • 12.28 did not change anything related to FTP/SFTP.

So if 12.27 was working, it may depend on when you installed it, but it's likely you had the Mar 23rd version with the additional fix, and nothing related should have changed since then.

It's also possible firewall or antivirus software's heuristics are reacting differently to the two executables, or have updated since things were working.

Or was it 12.26 which was the version where things worked for you? That would make more sense, as 12.27 was when a lot of SFTP code changed.

Perhaps it was 12.26 that worked. The FTP log has too much private information to post here.

I will say that after returning to an aborted connection after nearly an hour (about thirty minutes ago), the FTP connection was functional again.

So I closed all listers, hit my saved FTP shortcut and...same authentication problem as before. Maybe in an another hour the negotiation between server and DOpus will resolve again, but I can't work like that.

Can I DM you? I really can't post screenshots and logs here.

Yes, you can send a private message by clicking on my icon.

Many thanks for the log detail.

It looks like the server side is doing something wrong or unusual as WinSCP is also failing the initial connection attempt early on:

. 2022-06-17 07:29:24.722 Remote side unexpectedly closed network connection
. 2022-06-17 07:29:24.722 Using non-standard protocol or port, tunnel or proxy, will not knock FTP port.
* 2022-06-17 07:29:24.752 (EFatal) Server unexpectedly closed network connection.

I can't tell why the second WinSCP connection attempt 6 seconds later then succeeds. The log indicates all the settings are the same.

My guess is that the server or some part of the network (which includes firewalls/antivirus on each end) doesn't like something about the connection and is killing it. The issue doesn't look restricted to Opus, even if Opus is affected worse than WinSCP.

I've sent the Opus 12.26 and 12.27 installers via private message if you want to try them to test if the older version(s) still work with the current server/network.